POJ 2001Shortest Prefixes(字典树)

POJ 2001Shortest Prefixes(字典树)

Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 20706Accepted: 8939

Description

A prefix of a string is a substring starting at the beginning of the given string. The prefixes of “carbon” are: “c”, “ca”, “car”, “carb”, “carbo”, and “carbon”. Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, “carbohydrate” is commonly abbreviated by “carb”. In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents.
In the sample input below, “carbohydrate” can be abbreviated to “carboh”, but it cannot be abbreviated to “carbo” (or anything shorter) because there are other words in the list that begin with “carbo”.
An exact match will override a prefix match. For example, the prefix “car” matches the given word “car” exactly. Therefore, it is understood without ambiguity that “car” is an abbreviation for “car” , not for “carriage” or any of the other words in the list that begins with “car”.

Input

The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.

Output

The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.

Sample Input

carbohydrate
cart
carburetor
caramel
caribou
carbonic
cartilage
carbon
carriage
carton
car
carbonate

Sample Output

carbohydrate carboh
cart cart
carburetor carbu
caramel cara
caribou cari
carbonic carboni
cartilage carti
carbon carbon
carriage carr
carton carto
car car
carbonate carbona

题意

  给你一些单词(不知道数量,需要自己判断什么时候结束),现在让你输出这些单词的最短前缀,通过最短前缀可以直接确定是哪个单词。

解题思路

  可以直接利用给出的单词建字典树,然后再将这些单词查询一次,当sum数组对应的值为1的时候当前的前缀就是唯一的。至于控制输入,用while即可,类似于处理多组输入(笑)。string真的慢,换了char秒A。

代码

#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
const int maxn = 1e4+5;

int trie[maxn][26],sum[maxn],cnt;
char words[maxn][25],str[25];
void insert() {
    int len=strlen(str),root=0;
    for(int i=0; i<len; i++) {
        int id=str[i]-'a';
        if(!trie[root][id]) trie[root][id]=++cnt;
        sum[trie[root][id]]++;
        root=trie[root][id];
    }
}
void search() {
    string ss="";
    int len=strlen(str),root=0;
    for(int i=0; i<len; i++) {
        int id=str[i]-'a';
        root=trie[root][id];
        if(sum[root]!=1) ss+=str[i];
        else {
            ss+=str[i];
            cout<<str<<" "<<ss<<endl;
            return;
        }
    }
    cout<<str<<" "<<ss<<endl;
    return;
}
int main() {
//    freopen("in.txt","r",stdin);
    int cnt=0;
    while(~scanf("%s",words[cnt])) {
        int len=strlen(words[cnt]);
        for(int i=0; i<=len; i++)
            str[i]=words[cnt][i];
        cnt++;
        insert();
    }
    for(int i=0; i<cnt; i++) {
        int len=strlen(words[i]);
        for(int j=0; j<=len; j++)
            str[j]=words[i][j];
        search();
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值