J - Pangu and Stones HihoCoder - 1636 (区间DP)

In Chinese mythology, Pangu is the first living being and the creator of the sky and the earth. He woke up from an egg and split the egg into two parts: the sky and the earth.

At the beginning, there was no mountain on the earth, only stones all over the land.

There were N piles of stones, numbered from 1 to N. Pangu wanted to merge all of them into one pile to build a great mountain. If the sum of stones of some piles was S, Pangu would need S seconds to pile them into one pile, and there would be S stones in the new pile.

Unfortunately, every time Pangu could only merge successive piles into one pile. And the number of piles he merged shouldn't be less than L or greater than R.

Pangu wanted to finish this as soon as possible.

Can you help him? If there was no solution, you should answer '0'.

Input
There are multiple test cases.

The first line of each case contains three integers N,L,R as above mentioned (2<=N<=100,2<=L<=R<=N).

The second line of each case contains N integers a1,a2 …aN (1<= ai <=1000,i= 1…N ), indicating the number of stones of pile 1, pile 2 …pile N.

The number of test cases is less than 110 and there are at most 5 test cases in which N >= 50.

Output
For each test case, you should output the minimum time(in seconds) Pangu had to take . If it was impossible for Pangu to do his job, you should output 0.

Sample Input
3 2 2
1 2 3
3 2 3
1 2 3
4 3 3
1 2 3 4
Sample Output
9
6

0

题目大意:给你n个石头堆,再给个区间L,R。每次只能合并连续的k个石头堆(L<=k<=R),每次合并的花费,是合并后的石头堆的总重量。

区间DP:

dp[i][j][k]是指在i到j这个区间的石头堆合并成k堆石头的最小花费。

k=1时:
dp[i][j][1] = min(dp[i][p][x-1]+dp[p+1][j][1]+sum[i][j] (i<=p<=j-1;L<=x<=R) )
k>1时:
dp[i][j][k] = min(dp[i][p][k-1]+dp[p+1][j][1] ( i<=p<=j-1) )

#include<bits/stdc++.h>
using namespace std;
#define ll long long 
#define INF 0x3f3f3f3f
int n, L, R;
int a[110];
int dp[110][110][110];
int sum[110][110];
int main()
{
    while (scanf("%d%d%d", &n, &L, &R) != EOF) {
        for (int i = 1; i <= n; i++) {
            scanf("%d", &a[i]);
        }
        memset(dp, INF, sizeof(dp));
       
        memset(sum, 0,   sizeof(sum));
        for (int i = 1; i <= n; i++) {
            sum[i][i-1] = 0;
            for (int j = i; j <= n;j++) {
                sum[i][j] += sum[i][j-1] + a[j];
                dp[i][j][j-i+1] = 0;
            }
        }

        for (int d = 1; d < n;  d++) {
            for (int i = 1; i+d <= n; i++) {
                for (int p = 0; p < d; p++)
                    for (int k = L; k <= R; k++)
                        dp[i][i+d][1] = min(dp[i][i+d][1], dp[i][i+p][k-1] + dp[i+p+1][i+d][1] + sum[i][i+d]);
             
                for (int k = 2; k <= d; k++) {
                    for (int p = 0; p < d; p++)
                        dp[i][i+d][k] = min(dp[i][i+d][k], dp[i][i+p][k-1]+dp[i+p+1][i+d][1]);
                }   
            }
        }
        if (dp[1][n][1] == INF) {
            printf("0\n");
        }
        else printf("%d\n", dp[1][n][1]);
    }
    return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值