1108. Finding Average (20)

The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A “legal” input is a real number in [-1000, 1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100). Then N numbers are given in the next line, separated by one space.

Output Specification:

For each illegal input number, print in a line “ERROR: X is not a legal number” where X is the input. Then finally print in a line the result: “The average of K numbers is Y” where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output “Undefined” instead of Y. In case K is only 1, output “The average of 1 number is Y” instead.

Sample Input 1:
7
5 -3.2 aaa 9999 2.3.4 7.123 2.35
Sample Output 1:
ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38
Sample Input 2:
2
aaa -9999
Sample Output 2:
ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

这道题考的是字符串的处理,刚开始用的是动态vector做的,感觉麻烦,最后两个样例不知道为什么过不了,原来c,c++有的字符串处理函数真的十分好用,sscanf:sscanf与scanf类似,都是用于输入的,只是后者以键盘(stdin)为输入源,前者以固定字符串为输入源;sprintf:格式化字符串,将格式化的数据写入字符串中;
const char *c_str();
c_str()函数返回一个指向正规C字符串的指针常量, 内容与本string串相同.
atof(将字符串转换成浮点型数)
double atof(const char *nptr);
atoi(将字符串转换成整型数)
int atoi(const char *nptr);
atol(将字符串转换成长整型数)
long atol(const char *nptr);

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<string>
using namespace std;
bool judge(string s)
{
    int start = 0;
    if(s[0] == '-')
        start++;
    int dot = 0;
    int pos = s.size();
    for(int i = start;i < s.size();++i)
    {
        if(!(s[i] >= '0' && s[i] <= '9') && s[i] != '.')
        {
            return false;
        }
        if(s[i] == '.'){
            dot++;
            pos = i;
        }
        if(dot >= 2)
            return false;
    }
    if(s.size() - pos > 3)
        return false;
    double tmp;
    sscanf(s.c_str(),"%lf",&tmp);
    if(tmp > 1000 || tmp < -1000)
        return false;
    return true;
}
int main()
{
    int n;
    double sum = 0.0;
    int cnt = 0;
    scanf("%d",&n);
    string s;
    for(int i = 0;i < n;++i)
    {
        cin >> s;
        double tmp;
        if(judge(s)){
            sscanf(s.c_str(),"%lf",&tmp);
            sum += tmp;
            cnt++;
        }
        else{
            cout << "ERROR: " << s << " is not a legal number" << endl;
        }
    }
    if(cnt == 1) {
        printf("The average of 1 number is %.2lf", sum);
    } else if(cnt > 1) {
        printf("The average of %d numbers is %.2lf", cnt, sum / cnt);
    } else {
        printf("The average of 0 numbers is Undefined");
    }
    return 0;
}

更加简单的做法:

#include <iostream>
#include <string.h>
#include <cstdio>
#include <cstdlib>
using namespace std;
int main() {
    int n, cnt = 0;
    char a[50], b[50];
    double temp, sum = 0.0;
    cin >> n;
    for(int i = 0; i < n; i++) {
        scanf("%s", a);
        sscanf(a, "%lf", &temp);
        sprintf(b, "%.2lf",temp);
        int flag = 0;
        for(int j = 0; j < strlen(a); j++) {
            if(a[j] != b[j]) {
                flag = 1;
            }
        }
        if(flag || temp < -1000 || temp > 1000) {
            printf("ERROR: %s is not a legal number\n", a);
            continue;
        } else {
            sum += temp;
            cnt++;
        }
    }
    if(cnt == 1) {
        printf("The average of 1 number is %.2lf", sum);
    } else if(cnt > 1) {
        printf("The average of %d numbers is %.2lf", cnt, sum / cnt);
    } else {
        printf("The average of 0 numbers is Undefined");
    }
    return 0;
}

sprintf的链接:http://blog.csdn.net/nopoppy/article/details/52589745
sscanf的链接:http://blog.csdn.net/vitalia/article/details/52474761
字符串函数:http://blog.chinaunix.net/uid-276579-id-2450625.html
c_str函数:http://blog.csdn.net/nancy_m/article/details/7583550

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值