1108 Finding Average (20分)--PAT甲级真题

The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then N numbers are given in the next line, separated by one space.

Output Specification:
For each illegal input number, print in a line ERROR: X is not a legal number where X is the input. Then finally print in a line the result: The average of K numbers is Y where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined instead of Y. In case K is only 1, output The average of 1 number is Y instead.

Sample Input 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

Sample Output 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

Sample Input 2:

2
aaa -9999

Sample Output 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

题目大意:给出一系列数,求这些数的平均值;如果数组中出现不符合要求的数,要报错,并且不加入求平均值;

分析:这道题目考察字符处理;这道题目按部就班处理的话,可能要花一些时间;好在题目给了题目,说给一系列数字,但是aaa怎么当作数字呢?其实我们只要试图把他当作数字,就可以轻易的知道,他是一个不符合条件的数字,应该报错;合法的非数字符号只有负号’-'还有小数点’.‘;

#include<iostream>    
#include<string>
#include<cmath>
using namespace std; 
int main(){
	int n, cnt = 0;
	float t = 0;
	string arr[101];
	scanf("%d", &n);
	for (int i = 0; i < n; i++)
		cin >> arr[i];
	for (int i = 0; i < n; i++) {
		int flag = 1, pri = 0;
		int point = 0;//标志有没有检测到小数点'.'
		int fnum = 0;//小数点后数字位数
		float num = 0;
		int L = arr[i].length();
		for (int j = L - 1; j >= 0; j--) {
			if (arr[i][j] >= '0'&&arr[i][j] <= '9') {
				num =(arr[i][j] - '0')*pow(10, pri++) + num;
				if (point == 0)
					fnum++;
			}
			else if (arr[i][j] == '.') {
				if (point == 1 || fnum > 2)
					flag = 0;
				else
					point = 1;
			}
			else if (arr[i][j] == '-') {
				if (j != 0)
					flag = 0;
				else
					num = -num;
			}
			else
				flag = 0;
			if ((num > 1000 || num < -1000)&& point==0)
				flag = 0;
			if (flag == 0)
				break;
		}
		if (flag == 1) {
			if (point == 1)
				num /= pow(10, fnum);
			if (num < -1000 || num>1000)
				flag = 0;
			else {
				t += num;
				cnt++;
			}
		}
		if (flag == 0)
			printf("ERROR: %s is not a legal number\n", arr[i].c_str()); 
	}
	if (cnt == 0)
		printf("The average of 0 numbers is Undefined\n");
	else if(cnt==1)
		printf("The average of 1 number is %.2f\n", t/cnt);
	else
		printf("The average of %d numbers is %.2f\n",cnt, t/cnt);
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值