PAT A1040 Longest Symmetric String+DP最长回文串

1040 Longest Symmetric String (25 分)

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given Is PAT&TAP symmetric?, the longest symmetric sub-string is s PAT&TAP s, hence you must output 11.

Input Specification:

Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:

For each test case, simply print the maximum length in a line.

Sample Input:

Is PAT&TAP symmetric?

Sample Output:

11

代码:

#include <iostream>
#include <cstring>

const int maxn=1010;
char S[maxn];
int dp[maxn][maxn];

using namespace std;

int main()
{
    cin.getline(S,maxn);
    int len=strlen(S);
    int ans=1;
    memset(dp,0,sizeof(dp));

    //边界
    for(int i=0;i<len;i++){
        dp[i][i]=1;
        if(i<len-1){
            if(S[i]==S[i+1]){
                dp[i][i+1]=1;
                ans=2;
            }
        }
    }

    //状态转移方程

    int j;
    for(int L=3;L<=len;L++){  //每局子串长度
        for(int i=0;i+L-1<len;i++){ //i起点,j重点,[i,j]长度为L,且j<len
            j=i+L-1;
            if(S[i]==S[j] && dp[i+1][j-1]==1){ //回文串加串
                dp[i][j]=1;
                ans=L;
            }
        }
    }
    cout << ans;
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值