求二叉树的深度

Problem Description

已知一颗二叉树的中序遍历序列和后序遍历序列,求二叉树的深度。

Input

输入数据有多组,输入T,代表有T组数据。每组数据包括两个长度小于50的字符串,第一个字符串表示二叉树的中序遍历,第二个表示二叉树的后序遍历。

Output
输出二叉树的深度。
Example Input
2
dbgeafc
dgebfca
lnixu
linux
Example Output

43

 

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
typedef struct node
{
    char data;
    struct node *lc,*rc;
}bitree;
int max;
bitree * create(int zlen,char hst[51], char zst[51])
{
    if(zlen<=0)
        return NULL;
    int i;
    bitree * t;
    t=(bitree *)malloc(sizeof(bitree));
    t->data=hst[0];
    for(i=0;i<zlen;i++)
    {
        if(zst[i]==hst[0])
            break;
    }
    t->lc=create(i,hst-zlen+i,zst);
    t->rc=create(zlen-i-1,hst-1,zst+i+1);
    return t;
}
void pre_show(int count,bitree * t)
{
    int k;
    if(t)
    {
        if(count==0)
            count=1;
        k=count;
        if(k>max)
            max=k;
        pre_show(++k,t->lc);
        pre_show(++count,t->rc);
    }
}
int main()
{
    int zlen,hlen,t;
    char zst[51],hst[51];
    bitree * tree;
    scanf("%d",&t);
    while(t--)
    {
        max=0;
        scanf("%s%s",zst,hst);
        zlen=strlen(zst);
        hlen=strlen(hst);
        tree=create(zlen,hst+hlen-1,zst);
        pre_show(0,tree);
        printf("%d\n",max);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值