PAT 1113 Integer Set Partition python解法

1113 Integer Set Partition (25 分)
Given a set of N (>1) positive integers, you are supposed to partition them into two disjoint sets A​1 and A​2​​ of n​1​​ and n​2 numbers, respectively. Let S​1​​ and S​2​​ denote the sums of all the numbers in A​1​​ and A​2​​ , respectively. You are supposed to make the partition so that ∣n​1​​ −n​2​​ ∣ is minimized first, and then ∣S​1​​ −S​2​​ ∣ is maximized.
Input Specification:
Each input file contains one test case. For each case, the first line gives an integer N (2≤N≤10​5​​ ), and then N positive integers follow in the next line, separated by spaces. It is guaranteed that all the integers and their sum are less than 2​31​​ .

Output Specification:
For each case, print in a line two numbers: ∣n​1​​ −n​2​​ ∣ and ∣S​1​​ −S​2​​ ∣, separated by exactly one space.

Sample Input 1:
10
23 8 10 99 46 2333 46 1 666 555
Sample Output 1:
0 3611
Sample Input 2:
13
110 79 218 69 3721 100 29 135 2 6 13 5188 85
Sample Output 2:
1 9359

解题思路:先将数字排序,然后切成两半,用后一半减前一半。

n = int(input())
l = list(map(int,input().split()))
#n = 13
#l =[110, 79, 218, 69, 3721, 100, 29, 135, 2, 6, 13, 5188, 85]
l.sort()
#l1 = l[:n//2]
#l2 = l[n//2:n]
#s1 = sum(l1)
#s2 = sum(l2)
#print(len(l2)-len(l1),s2-s1)
print(len(l[n//2:n])-len(l[:n//2]),sum(l[n//2:n])-sum(l[:n//2]))
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

D_ry

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值