Weighted Median(山东省第五届ACM大学生程序设计竞赛 )

Problem Description
For n elements x1, x2, ..., xn with positive integer weights w1, w2, ..., wn. The weighted median is the element xk satisfying
 and   , S indicates 
Can you compute the weighted median in O(n) worst-case?
 
Input
There are several test cases. For each case, the first line contains one integer n(1 ≤  n ≤ 10^7) — the number of elements in the sequence. The following line contains n integer numbers xi (0 ≤ xi ≤ 10^9). The last line contains n integer numbers wi (0 < wi < 10^9).
 
Output
One line for each case, print a single integer number— the weighted median of the sequence.
 
Example Input
7
10 35 5 10 15 5 20
10 35 5 10 15 5 20
Example Output
20
Hint
The S which indicates the sum of all weights may be exceed a 32-bit integer. If S is 5,  equals 2.5.


题意:给你xi、wi,找的符合满足上面式子的sk;

思路:就是一个结构体排序,然后从前往后加,大于就输出;

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <cmath>
#include <algorithm>
#include <vector>
#include <map>
#include <string>
#include <stack>
#define LL long long
#define INF 0x7fffffff
#define MAX 10000010
#define PI 3.1415926535897932
#define E 2.718281828459045
using namespace std;
struct edge
{
    int x,w;
};
bool cmp(edge X,edge Y)
{
    return X.x<Y.x;
}
edge G[MAX];
double sum;
int n;
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        sum=0;
        for(int i=0; i<n; i++)
        {
            scanf("%d",&G[i].x);
        }
        for(int i=0; i<n; i++)
        {
            scanf("%d",&G[i].w);
            sum+=G[i].w;
        }
        sum=sum/2.0;
        sort(G,G+n,cmp);
        double ss=0;
        for(int i=0; i<n; i++)
        {
            ss+=G[i].w;
            if(ss>=sum)
            {
                printf("%d\n",G[i].x);
                break;
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值