POJ - 2533 Longest Ordered Subsequence

Longest Ordered Subsequence
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 59740 Accepted: 26772

Description

A numeric sequence of  ai is ordered if  a1 <  a2 < ... <  aN. Let the subsequence of the given numeric sequence ( a1a2, ...,  aN) be any sequence ( ai1ai2, ...,  aiK), where 1 <=  i1 <  i2 < ... <  iK <=  N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

Source

Northeastern Europe 2002, Far-Eastern Subregion

题意:求最长上升子序列;

题解:设a[i]是前i个数字的最长上升子序列的长度,则对于{j < i, a[j] < a[i] | a[i] = max(a[i], a[j] + 1)}。算法时间复杂度为O(n^2);

优化方案:我们注意到,在第i位,如果有若干个长度相同的最长上升子序列,我们更应该选择最大值最小的子序列(最大值越小在后面的序列中选择范围越大)。同理,在第i - 1位也应该执行上诉方案。于是,我们可以得到一个结论,在长度相同的情况下,应该更努力地使当前的最长上升子序列中的各元素的值变小(当前位影响后一位)。因此,我们维护一个数组,存储当前最长上升子序列的元素,对于第k位

一、如果它比当前数组的最大值还大,则最长上升子序列的长度加1,将该元素加入数组;

二、如果相等则不进行任何操作;(当前数组没有任意元素能被替代)

三、如果比最大值小,则在数组中寻找到第一个比该元素大的元素,将它替换(长度不变,更倾向用更小的值)。寻找的过程可以用二分来实现。

基于以上操作,本题可以时间复杂度优化成O(nlogn)

AC代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<string>
#include<vector>

using namespace std;

const int maxn = 1111;
int q[maxn];

int main()
{
	int n, c;
	scanf("%d", &n);
	int now = 1;
	q[0] = -1;
	for(int i = 0; i < n; i++){
		scanf("%d", &c);
		if(c > q[now - 1]){
			q[now] = c;
			now++;
		}
		else if(c == q[now - 1])
			continue;
		else{
			int l = 0, r = now;
			while(l < r){
				int m = (l + r) / 2;
				if(q[m] > c)
					r = m;
				else
					l = m + 1;
			}
			q[l] = c;
		}
	}
	printf("%d\n", now - 1);
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值