【PAT甲级A1013】Battle Over Cities (25分)(c++)

1013 Battle Over Cities (25分)

作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:400 ms
内存限制:64 MB

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city​1-city​2​​ and city1​​ -city​3​​ . Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2 -city3.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:
For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

题意:
给出总结点数,连通数,以及所关心的结点数(就是说关心的结点都会假设被去除)。输出每个关心结点被去除后,使得剩余结点联通所需的额外连接条数。
思路:
求剩余结点联通所需的额外连接数,就是在计算剩余节点共有几个联通块,条数无非就是总连通块个数-1。于是这题就是dfs图的遍历,去除关心点,就是将关心点置为已访问flag[concern]=true,然后遍历图,计算连通块的个数。
参考代码:

#include <iostream>
using namespace std;
const int maxn=1010;
const int INF=1e9;
int G[maxn][maxn]={0};
bool flag[maxn];
int n,m,k;
void dfs(int u){
    flag[u]=true;
    for(int v=1;v<=n;v++)
        if(!flag[v]&&G[u][v]>0)
            dfs(v);
}
int main() {
    cin>>n>>m>>k;
    int x,y,concern;
    for(int i=1;i<=m;i++){
        cin>>x>>y;
        G[x][y]=G[y][x]=1;
    }
    for(int i=0;i<k;i++){
        fill(flag,flag+maxn,0);
        cin>>concern;
        flag[concern]=true;
        int cnt=0;
        for(int j=1;j<=n;j++){
            if(!flag[j]){
                dfs(j);
                cnt++;
            }
        }
        cout<<cnt-1<<endl;
    }
    return 0;
}

如有错误,欢迎指正

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值