【PAT甲级A1086】Tree Traversals Again (25分)(c++)

1086 Tree Traversals Again (25分)

作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:400 ms
内存限制:64 MB

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.

在这里插入图片描述

Figure 1
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.

Output Specification:
For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

题意:

将一组点按照所给进入栈顺序能得到一颗中序的二叉树,要求输出这颗二叉树的后序遍历。

思路:

这题的关键在于意识到,所给点的入栈顺序其实是二叉树的谦虚遍历。于是题意就能理解为,给出一棵二叉树的中序和前序遍历,求它的后序输出。

参考代码:

#include <iostream>
#include <algorithm>
#include <vector>
#include <stack>

using namespace std;
struct node {
    int data;
    node *left, *right;
};
vector<int> pre, in;
int n, data, cnt = 0;

node *create(int prel, int prer, int inl, int inr) {
    if (prel > prer)return NULL;
    node *root = new node;
    root->data = pre[prel];
    int k;
    for (k = inl; k <= inr; k++)
        if (in[k] == pre[prel])break;
    int numleft = k - inl;
    root->left = create(prel + 1, prel + numleft, inl, k - 1);
    root->right = create(prel + numleft + 1, prer, k + 1, inr);
    return root;
}

void postorder(node *root) {
    if (root == NULL)return;
    postorder(root->left);
    postorder(root->right);
    if (cnt != 0)printf(" ");
    printf("%d", root->data);
    cnt++;
}

int main() {
    char str[5];
    stack<int> st;
    scanf("%d", &n);
    while (in.size() != n || pre.size() != n) {
        scanf("%s", str);
        if (str[1] == 'u') {
            scanf("%d", &data);
            pre.push_back(data);
            st.push(data);
        } else {
            in.push_back(st.top());
            st.pop();
        }
    }
    postorder(create(0, n - 1, 0, n - 1));
    return 0;
}

如有错误,欢迎指正

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值