【PAT甲级A1108】 Finding Average (20分)(c++)

1108 Finding Average (20分)

作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:400 ms
内存限制:64 MB

The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then N numbers are given in the next line, separated by one space.

Output Specification:
For each illegal input number, print in a line ERROR: X is not a legal number where X is the input. Then finally print in a line the result: The average of K numbers is Y where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined instead of Y. In case K is only 1, output The average of 1 number is Y instead.

Sample Input 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

Sample Output 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

Sample Input 2:

2
aaa -9999

Sample Output 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

题意:

判断所给数字是否符合条件(小于等于1000且大于等于-1000,且最多两位小数)或是否为数字。输出有效数字的平均数。

思路:

用sscanf将字符串表示成浮点数(从左到右),sprintf将浮点数保留两位有效数字保存进字符串(从右到左)。比较读取的字符串和转换后的字符串,若转换后的字符串在原有长度下每位都相等,那么这个数就是数字。

参考代码:

#include <iostream>
#include <cstring>

using namespace std;

int main() {
    int n, cnt = 0;
    char a[50], b[50];
    double sum = 0, temp;
    scanf("%d", &n);
    for (int i = 0; i < n; i++) {
        scanf("%s", a);
        sscanf(a, "%lf", &temp);
        sprintf(b, "%.2f", temp);
        bool flag = true;
        for (int j = 0; j < strlen(a); j++)
            if (a[j] != b[j]) flag = false;
        if (flag && temp >= -1000 && temp <= 1000) {
            sum += temp;
            cnt++;
        } else printf("ERROR: %s is not a legal number\n", a);
    }
    if (cnt >= 1)printf("The average of %d number%s is %.2f", cnt, cnt == 1 ? "" : "s", sum / cnt);
    else printf("The average of 0 numbers is Undefined\n");
    return 0;
}

如有错误,欢迎指正

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值