1108. Finding Average

1108. Finding Average (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A "legal" input is a real number in [-1000, 1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100). Then N numbers are given in the next line, separated by one space.

Output Specification:

For each illegal input number, print in a line "ERROR: X is not a legal number" where X is the input. Then finally print in a line the result: "The average of K numbers is Y" where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output "Undefined" instead of Y. In case K is only 1, output "The average of 1 number is Y" instead.

Sample Input 1:
7
5 -3.2 aaa 9999 2.3.4 7.123 2.35
Sample Output 1:
ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38
Sample Input 2:
2
aaa -9999
Sample Output 2:
ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined
这题别想太多,判断下第一个符号‘-’和中间的‘.’,想多容易出错,各种不规范的输入如1. 001等都是合法的。
#include<iostream>
#include<string>
#include<vector>
#include<algorithm>

using namespace std;

double sum=0;
int cnt=0;

double s2d(string s)
{
	int k=0;
	double d1=0,d2=0;
	double d=0;
	bool f=true;
	if(s.empty())
		return 0;
	if(s[0]=='-')
		k++;
	else if(s[0]>='0'&&s[0]<='9')
		;
	else
	{
		cout<<"ERROR: "<<s<<" is not a legal number"<<endl;
		return 0;
	}
	int pos=s.find('.');
	if(pos!=string::npos)
	{
		//cout<<"---"<<endl;
		for(int i=k;i<pos;i++)
		{
			if(s[i]>='0'&&s[i]<='9')
				d1=d1*10+s[i]-'0';
			else
			{
				f=false;
				break;
			}
		}
		if(s.size()-pos<4)
		{
			for(int i=s.size()-1;i>pos;i--)
			{
				if(s[i]>='0'&&s[i]<='9')
					d2=d2/10+s[i]-'0';
				else
				{
					f=false;
					break;
				}
			}
			d2=d2/10;
		}
		else
			f=false;
	}
	else
	{
		for(int i=k;i<s.size();i++)
		{
			if(s[i]>='0'&&s[i]<='9')
				d1=d1*10+s[i]-'0';
			else
			{
				f=false;
				break;
			}
		}
	}
	d=d1+d2;
	if(abs(d1+d2)>1000)
		f=false;
	if(f==false)
	{
		cout<<"ERROR: "<<s<<" is not a legal number"<<endl;
		return 0;
	}
	else
	{
		cnt++;
		return k==0?(d1+d2):(-d1-d2);
	}
}

int main()
{
	int n;
	cin>>n;
	for(int i=0;i<n;i++)
	{
		string s;
		cin>>s;
		sum+=s2d(s);
	}
	if(cnt==0)
		cout<<"The average of 0 numbers is Undefined"<<endl;
	else if(cnt==1)
		printf("The average of %d number is %.2lf\n",cnt,sum/cnt);
	else
		printf("The average of %d numbers is %.2lf\n",cnt,sum/cnt);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值