1150 Travelling Salesman Problem (25分)
作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:400 ms
内存限制:64 MB
The “travelling salesman problem” asks the following question: “Given a list of cities and the distances between each pair of cities, what is the shortest possible route that visits each city and returns to the origin city?” It is an NP-hard problem in combinatorial optimization, important in operations research and theoretical computer science. (Quoted from “https://en.wikipedia.org/wiki/Travelling_salesman_problem”.)
In this problem, you are supposed to find, from a given list of cycles, the one that is the closest to the solution of a travelling salesman problem.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of cities, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format City1 City2 Dist, where the cities are numbered from 1 to N and the distance Dist is positive and is no more than 100. The next line gives a positive integer K which is the number of paths, followed by K lines of paths, each in the format:
n C1 C2 ... Cn
where n is the number of cities in the list, and Ci 's are the cities on a path.
Output Specification:
For each path, print in a line Path X: TotalDist (Description) where X is the index (starting from 1) of that path, TotalDist its total distance (if this distance does not exist, output NA instead), and Description is one of the following:
TS simple cycle if it is a simple cycle that visits every city;
TS cycle if it is a cycle that visits every city, but not a simple cycle;
Not a TS cycle if it is NOT a cycle that visits every city.
Finally print in a line Shortest Dist(X) = TotalDist where X is the index of the cycle that is the closest to the solution of a travelling salesman problem, and TotalDist is its total distance. It is guaranteed that such a solution is unique.
Sample Input:
6 10
6 2 1
3 4 1
1 5 1
2 5 1
3 1 8
4 1 6
1 6 1
6 3 1
1 2 1
4 5 1
7
7 5 1 4 3 6 2 5
7 6 1 3 4 5 2 6
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 2 5 4 3 1
7 6 3 2 5 4 1 6
Sample Output:
Path 1: 11 (TS simple cycle)
Path 2: 13 (TS simple cycle)
Path 3: 10 (Not a TS cycle)
Path 4: 8 (TS cycle)
Path 5: 3 (Not a TS cycle)
Path 6: 13 (Not a TS cycle)
Path 7: NA (Not a TS cycle)
Shortest Dist(4) = 8
题意:
给出若干点和边,判断路径是否是经过每个点的最小环。并输出所给路径中路程最短的。
思路:
若是经过每个点的最小环,则要满足
- 总结点数为n+1;
- 结点首尾相同;
- 每个结点都有访问到;
- 每条路径都要相通
首先用邻接矩阵记录连通边,遍历路径,若相通则路程相加,否则输出NA,再判断是否每个点有访问到(用哈希表记录)以及是否首尾对应,记录路程更新最短值与下标值。根据不通情况输出。
参考代码:
#include <cstdio>
#include <vector>
using namespace std;
const int maxn = 201;
int G[maxn][maxn];
int main() {
int n, m, k, t, a, b, d;
scanf("%d%d", &n, &m);
for (int i = 0; i < m; i++) {
scanf("%d%d%d", &a, &b, &d);
G[a][b] = G[b][a] = d;
}
scanf("%d", &k);
int ans = 1e9, index = 0;
for (int i = 1; i <= k; i++) {
int dis = 0, flag = 0;
scanf("%d", &t);
vector<int> v(t), hash(n + 1, 0), temp(n + 1, 1);
hash[0] = 1;
for (int j = 0; j < t; j++) {
scanf("%d", &v[j]);
if (j > 0) {
if (G[v[j]][v[j - 1]] != 0)dis += G[v[j]][v[j - 1]];
else flag = 1;
}
hash[v[j]] = 1;
}
printf("Path %d: ", i);
if (!flag)printf("%d", dis);
else printf("NA");
if (v[0] != v[t - 1] || hash != temp)flag = 1;
if (!flag && dis < ans) {
ans = dis;
index = i;
}
if (!flag && t == n + 1)printf(" (TS simple cycle)\n");
else if (!flag)printf(" (TS cycle)\n");
else printf(" (Not a TS cycle)\n");
}
printf("Shortest Dist(%d) = %d", index, ans);
return 0;
}
如有错误,欢迎指正