A1150 Travelling Salesman Problem(25分)PAT 甲级(Advanced Level) Practice(C++)满分题解【旅行商问题+set】

The "travelling salesman problem" asks the following question: "Given a list of cities and the distances between each pair of cities, what is the shortest possible route that visits each city and returns to the origin city?" It is an NP-hard problem in combinatorial optimization, important in operations research and theoretical computer science. (Quoted from "https://en.wikipedia.org/wiki/Travelling_salesman_problem".)

In this problem, you are supposed to find, from a given list of cycles, the one that is the closest to the solution of a travelling salesman problem.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of cities, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format City1 City2 Dist, where the cities are numbered from 1 to N and the distance Dist is positive and is no more than 100. The next line gives a positive integer K which is the number of paths, followed by K lines of paths, each in the format:

n C1​ C2​ ... Cn​

where n is the number of cities in the list, and Ci​'s are the cities on a path.

Output Specification:

For each path, print in a line Path X: TotalDist (Description) where X is the index (starting from 1) of that path, TotalDist its total distance (if this distance does not exist, output NA instead), and Description is one of the following:

  • TS simple cycle if it is a simple cycle that visits every city;
  • TS cycle if it is a cycle that visits every city, but not a simple cycle;
  • Not a TS cycle if it is NOT a cycle that visits every city.

Finally print in a line Shortest Dist(X) = TotalDist where X is the index of the cycle that is the closest to the solution of a travelling salesman problem, and TotalDist is its total distance. It is guaranteed that such a solution is unique.

Sample Input:

6 10
6 2 1
3 4 1
1 5 1
2 5 1
3 1 8
4 1 6
1 6 1
6 3 1
1 2 1
4 5 1
7
7 5 1 4 3 6 2 5
7 6 1 3 4 5 2 6
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 2 5 4 3 1
7 6 3 2 5 4 1 6

Sample Output:

Path 1: 11 (TS simple cycle)
Path 2: 13 (TS simple cycle)
Path 3: 10 (Not a TS cycle)
Path 4: 8 (TS cycle)
Path 5: 3 (Not a TS cycle)
Path 6: 13 (Not a TS cycle)
Path 7: NA (Not a TS cycle)
Shortest Dist(4) = 8

题意分析:

主要是注意各个类型之间的逻辑判断顺序

在记录每一个城市的访问次数的时候,之前用的是用数组visit来记录每个城市的次数,但是看了柳神的题解之后发现了更好的方法,就是用集合set来记录,这里利用了集合的特性,重复元素不会重复计算,刚好符合需求,并且在判断的时候更方便。

代码如下:

#include<bits/stdc++.h>
using namespace std;
int n, m, k;//城市数,道路数,查询路线数
int road[210][210];//邻接表,直接对应两个城市之间的距离
int main()
{
	cin >> n >> m;
	int c1, c2, dis;
	while (m--) {
		cin >> c1 >> c2 >> dis;
		road[c1][c2] = road[c2][c1] = dis;
	}
	cin >> k;
	int num, t = 0, res = INT_MAX,resIndex=0;
	while (t != k) {
		cin >> num;
		vector<int> path(num);//给定路线
		//用集合set来存放节点,重复的只计算一个,用来代替原来写的visit
		set<int> visit;
		int sum = 0;//总距离
		for (int i = 0; i < num; i++) {
			cin >> path[i];
			visit.insert(path[i]);
		}
		int flag = 1, curr, pre = path[0];//flag用来判断是不是连通
		for (int i = 1; i < num; i++) {
			curr = path[i];
			if (road[pre][curr] == 0)flag = 0;
			sum += road[pre][curr];
			pre = curr;
		}
		t++;
		if (flag == 0)cout << "Path " << t << ": NA (Not a TS cycle)" << endl;
		else if (visit.size() != n || path[0] != path[num - 1])cout << "Path " << t << ": " << sum << " (Not a TS cycle)" << endl;
		else {
			if (sum < res) {
				resIndex = t;
				res = sum;
			}
			if (num != n + 1)cout << "Path " << t << ": " << sum << " (TS cycle)" << endl;
			else cout << "Path " << t << ": " << sum << " (TS simple cycle)" << endl; 
		}
	}
	cout << "Shortest Dist(" << resIndex << ") = " << res << endl;
	return 0;
}

运行结果如下:

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值