POJ 1456 Supermarket(贪心)

11 篇文章 0 订阅

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σ  x∈Sellpx. An optimal selling schedule is a schedule with a maximum profit. 
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80. 

Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products. 
Input
A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.
Output
For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.
Sample Input
4  50 2  10 1   20 2   30 1

7  20 1   2 1   10 3  100 2   8 2
   5 20  50 10
Sample Output
80
185
Hint
The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.


题解:

给你一堆商品的价格和他卖出的截止时间(从1开始算),卖一个商品占一个单位时间,问你最大利润是多少

思路:

根据商品的截止时间从小到大排下序,然后遍历时间,如果当前商品截止时间小于等于当前时间就放入,每一个单位时间内取出最大价值的那个,过程可以用优先队列模拟,就是建一个关于截止时间从小到大的最小堆

代码:

#include<iostream>
#include<cstring>
#include<stdio.h>
#include<math.h>
#include<string>
#include<stdio.h>
#include<algorithm>
#include<queue>
#include<stack>
#include<map>
#include<vector>
#include<deque>
using namespace std;
#define lson k*2
#define rson k*2+1
#define M (t[k].l+t[k].r)/2
#define INF 100861111
#define ll long long
#define eps 1e-15
struct node
{
    int v;
    int t;
    friend bool operator<(node x,node y)//根据截止时间从小到大排序
    {
        return x.t>y.t;
    }
}a[10005];
priority_queue<int>q;
int main()
{
    int v,i,j,n,x,y,maxx;
    while(scanf("%d",&n)!=EOF)
    {
        maxx=0;
        for(i=0;i<n;i++)
        {
            scanf("%d%d",&a[i].v,&a[i].t);
            if(a[i].t>maxx)
                maxx=a[i].t;
        }
        sort(a,a+n);
        int sum=0;
        j=0;
        while(!q.empty())
            q.pop();
        for(i=maxx;i>=1;i--)
        {
            while(j<n&&a[j].t>=i)//当前时间大于等于当前商品的截止时间
            {
                q.push(a[j].v);
                j++;
            }
            if(!q.empty())
            {
                sum+=q.top();
                q.pop();
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值