POJ - 1456 Supermarket(贪心+并查集优化)

Supermarket

Description

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σx∈Sellpx. An optimal selling schedule is a schedule with a maximum profit.
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80.
在这里插入图片描述
Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products.
Input

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.
Output

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.
Sample Input

4 50 2 10 1 20 2 30 1

7 20 1 2 1 10 3 100 2 8 2
5 20 50 10
Sample Output

80
185
Hint

The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.

题意:超市里有一些特价商品,每件商品都有两个属性,一个是利润pi,另一个是截止日期di(就是说这件商品在截止日期di之前售出的话,就可以获得pi的利润)。最后要求能够获得的最大利润。

思路:就是一道贪心的题目,让利润高的商品先安排售出,从这个商品的截止日期往前找,用vis[x]数组来记录所有时间的值,如果vis[x]==0,就代表还没有商品在这个时间卖出,就可以把这个商品安排在这个时间,更新vis[x]的值为这个商品的利润;如果vis[x]!=0,就代表已经有商品被安排在这个时间出售了,而且利润肯定大于此时的这个商品,所以就继续往前找。

其实这题可以用并查集优化,从上面可以看出每个商品都要从它的截止时间开始往前找,这样的话时间复杂度就会很高,所以可以考虑减少搜索的次数。可以用并查集优化一下,设pre[x]数组是最接近x的没有没被占有的时间点,所以每次直接访问pre[di]就可以找到那个商品可以被安排售出的时间。

普通贪心的代码:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<set>
#include<map>
#include<iostream>
#include<algorithm>
using namespace std;

#define ll long long
const int inf=0x3f3f3f3f;
const int maxn=10010;
#define eps 1e-8

struct node
{
    int p,d;
} a[maxn];

bool cmp(node x,node y)
{
    return x.p>y.p;
}
int n;
int vis[maxn];

int main()
{
    while(cin>>n)
    {
        memset(vis,0,sizeof(vis));
        int maxx=-1;
        for(int i=1; i<=n; i++)
        {
            cin>>a[i].p>>a[i].d;
            maxx=max(maxx,a[i].d);
        }
        sort(a+1,a+n+1,cmp);
        for(int i=1; i<=n; i++)
        {
            for(int j=a[i].d; j>0; j--)
            {
                if(vis[j]==0)
                {
                    vis[j]=a[i].p;
                    break;
                }
            }
        }
        int ans=0;
        for(int i=1;i<=maxx;i++)
            if(vis[i]) ans+=vis[i];
        cout<<ans<<endl;
    }
    return 0;
}

用并查集优化的代码:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<set>
#include<map>
#include<iostream>
#include<algorithm>
using namespace std;

#define ll long long
const int inf=0x3f3f3f3f;
const int maxn=10010;
#define eps 1e-8

struct node
{
    int p,d;
} a[maxn];

bool cmp(node x,node y)
{
    return x.p>y.p;
}

int n;
int vis[maxn],pre[maxn];

int Find(int x)
{
    return pre[x]==-1?x:pre[x]=Find(pre[x]);
}

int main()
{
    while(cin>>n)
    {
        memset(vis,0,sizeof(vis));
        memset(pre,-1,sizeof(pre));
        for(int i=1; i<=n; i++)
            cin>>a[i].p>>a[i].d;
        sort(a+1,a+n+1,cmp);
        int ans=0;
        for(int i=1; i<=n; i++)
        {
            int tmp=Find(a[i].d);
            if(tmp>0)
            {
                ans+=a[i].p;
                pre[tmp]=tmp-1;
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值