Eddy's picture 最小生成数 kruskal

Eddy's picture

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10589    Accepted Submission(s): 5353


Problem Description
Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.
Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws? 

Input
The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point. 

Input contains multiple test cases. Process to the end of file.
 

Output
Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points. 
 

Sample Input
  
  
3 1.0 1.0 2.0 2.0 2.0 4.0
 

Sample Output
  
  
3.41
 
Author
eddy
 
Recommend
JGShining



最小生成树  将点的输入顺序做个编号,也即是第几个输入个为几号,燃后把每两个点的距离求出来,和对应的顶点一起放入结构体 之后用kruskal算法

#include<iostream>
#include<string>
#include<string.h>
#include<cstdio>
#include<algorithm>
#include<math.h> 
using namespace std;
int par[10000];
void init(int n)
{
    for(int i=0;i<=n;i++)
    {
        par[i]=i;
    }
}
int find(int x)
{
    return par[x]==x?x:par[x]=find(par[x]);
}
void unit(int ax,int ay)
{
    par[ay]=ax;
}
struct edge{int u,v;double cost;};


bool cmp(const edge e1,const edge e2)
{
    return e1.cost<e2.cost;
}
edge es[10000];//边的权值 
int e,n;
void  kruskal()
{
    sort(es,es+e,cmp);
    init(n);
    double res=0;
    for(int i=0;i<e;i++)
    {
        edge s=es[i];
        int ax=find(s.v);
        int ay=find(s.u);
        if(ax!=ay)
        {
            unit(ax,ay);
            res+=s.cost;
        }
    }
    printf("%.2f\n",res);
}
struct node
{
    double x;
    double y;
}ee[10010];
int o,s1,s2,w;
char s,k;
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        e=0;
        for(int i=0;i<n;i++)
        {
            cin>>ee[i].x>>ee[i].y;
        }
        for(int i=0;i<n;i++)
        {
            for(int j=i+1;j<n;j++)
            {
                es[e].u=i;es[e].v=j;
                es[e].cost=sqrt((ee[i].x-ee[j].x)*(ee[i].x-ee[j].x)+(ee[i].y-ee[j].y)*(ee[i].y-ee[j].y));
                e++;
            }
        }
        kruskal();
    }
    return 0;
}
人一我百!人十我万!永不放弃~~~怀着自信的心,去追逐梦想。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

じ☆夏妮国婷☆じ

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值