PAT 2002-A+B for Polynomials

1002 A+B for Polynomials (25)(25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 a~N1~ N2 a~N2~ ... NK a~NK~, where K is the number of nonzero terms in the polynomial, Ni and a~Ni~ (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 2 1.5 1 2.9 0 3.2
作者: CHEN, Yue
单位: PAT联盟
时间限制: 400ms
内存限制: 64MB
代码

Answer:

此题主要考察C++中map的使用,主要需要操作有find(),erase(),count(), []符号等。该题比较简单。坑点在于,如果相加后某项的系数为零,需要删去该项。我实现的较复杂,看了其他的答案,发现可以用逆向迭代器去遍历,这样就可以不用vector了。明天把C++迭代器一节看看。

#include<iostream>
#include<map>
#include<vector>
#include<algorithm>

using namespace std;

int main()
{
	map<int, double>  poly;
	int n; //分别记录每一行的项数
	int a;
	double b;
	
	cin >> n;
	while(n--){
		cin >> a >> b;
		pair<int, double> item(a, b);
		poly.insert(item);
	}
	cin >> n;
	while(n--)
	{
		cin >> a >> b;
		pair<int, double> item(a, b);
		if( poly.count(a) ){
			poly[a] += b;
		}else{
			poly.insert(item);
		}	
	}
	//输出
	int count = 0;
	for(map<int, double>::iterator iter = poly.begin(); iter != poly.end(); ++iter)
	{
		if(iter->second == 0){
			count++;
		}
	}
	printf("%d", poly.size()-count); 
	vector<pair<int, double> > vec(poly.begin(), poly.end());
	reverse(vec.begin(), vec.end());
	for(vector<pair<int, double> >::iterator iter = vec.begin(); iter != vec.end(); ++iter){
		if(iter->second != 0){
			printf(" %d %.1f", iter->first, iter->second);
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值