PAT 1049 Counting Ones (30)

The task is simple: given any positive integer N, you are supposed to count the total number of 1's in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1's in 1, 10, 11, and 12.

Input Specification:

Each input file contains one test case which gives the positive N (<=2^30^).

Output Specification:

For each test case, print the number of 1's in one line.

Sample Input:

12

Sample Output:

5

解答:刚开始计算时,使用了暴力求解,结果有两个超时,超时的代码如下一。后来借鉴了其他博客的求解思路。解题时,需要考查数值的每位数,分别对该数的值为0、1和>=2进行考察,进而计算得到结果。

超时代码:

#include<iostream>

using namespace std;


int main()
{
	long long positive;
	int count = 0;
	
	cin >> positive;
	for(int i = 1; i <= positive; ++i)
	{
		int val = i;
		while(val)
		{
			if(val % 10 == 1)
			{
				count++;
			}
			val /= 10;
		}
	}
	cout << count << endl;
	return 0;
} 

AC代码如下:

#include<iostream>

using namespace std;

using ll = long long;

int main()
{
	int N;
	int a = 1, left, right, now;
	int count = 0;
	
	cin >> N;
	while(N / a)
	{
		left = N / (a*10);
		right = N % a;
		now = N / a % 10;
		if( now == 0 )
		{
			count += left * a;
		}
		else if( now == 1 )
		{
			count += (left * a + right + 1);
		} 
		else 
		{
			count += (left+1)*a;
		}
		a = a * 10;
	}
	cout << count << endl;
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值