[USACO4.2.2]The Perfect Stall

The Perfect Stall
Hal Burch

Farmer John completed his new barn just last week, complete with all the latest milking technology. Unfortunately, due to engineering problems, all the stalls in the new barn are different. For the first week, Farmer John randomly assigned cows to stalls, but it quickly became clear that any given cow was only willing to produce milk in certain stalls. For the last week, Farmer John has been collecting data on which cows are willing to produce milk in which stalls. A stall may be only assigned to one cow, and, of course, a cow may be only assigned to one stall.

Given the preferences of the cows, compute the maximum number of milk-producing assignments of cows to stalls that is possible.

PROGRAM NAME: stall4

INPUT FORMAT

Line 1:One line with two integers, N (0 <= N <= 200) and M (0 <= M <= 200). N is the number of cows that Farmer John has and M is the number of stalls in the new barn.
Line 2..N+1:N lines, each corresponding to a single cow. The first integer (Si) on the line is the number of stalls that the cow is willing to produce milk in (0 <= Si <= M). The subsequent Si integers on that line are the stalls in which that cow is willing to produce milk. The stall numbers will be integers in the range (1..M), and no stall will be listed twice for a given cow.

SAMPLE INPUT (file stall4.in)

5 5
2 2 5
3 2 3 4
2 1 5
3 1 2 5
1 2 

OUTPUT FORMAT

A single line with a single integer, the maximum number of milk-producing stall assignments that can be made.

SAMPLE OUTPUT (file stall4.out)

4


题意:

二分图最大匹配


分析:

网络流的方法就是

建立一个源点,一个汇点

把左边的和源点连边,右边的和汇点连边,构建一幅图

——图片来源于网络

然后跑最大流

当然,我学习了一下匈牙利算法。

效率不错。——虽然比不上dinic

做法就是:

枚举所有左边的点,然后找一条可以满足的增广路(增广路满足其为当前点为左端点,以某个右边的未匹配的点为右端点,那么这条增广路是满足条件的)

然后更新答案,直到全部做完

时间复杂度O(n^3),dinic好像只要O(sqrt(n) * m)

但是匈牙利算法比较短,而且,

高效的KM算法基于这个(而费用流就复杂多了,虽然我并不知道费用流)

/*
ID:cqz15311
LANG:C++
PROG:stall4
*/
#include<bits/stdc++.h>
int n,m,ans;
int Map[205][205],link[205];
bool vis[205];
using namespace std;
bool Hungary(int u){
	for (int v=1;v<=m;v++){
		if (!vis[v] && Map[u][v]){
			vis[v] = true;
			if (link[v] == -1 || Hungary(link[v])){
				link[v] = u;
				return true;
			}
		}
	}
	return false;
}
int c,x;
int main(){
	freopen("stall4.in","r",stdin);
	freopen("stall4.out","w",stdout);
	memset(Map,false,sizeof(Map));
	scanf("%d%d",&n,&m);
	for (int i=1;i<=n;i++){
		scanf("%d",&c);
		while (c--){
			scanf("%d",&x);
			Map[i][x] = true;
		}
	}
	ans = 0;
	memset(link,-1,sizeof(link));
	for (int k=1;k<=n;k++){
		memset(vis,false,sizeof(vis));
		if (Hungary(k)) ans++;
	}
	printf("%d\n",ans);
	fclose(stdin);
	fclose(stdout);
}
/*
Executing...
   Test 1: TEST OK [0.000 secs, 4344 KB]
   Test 2: TEST OK [0.000 secs, 4344 KB]
   Test 3: TEST OK [0.000 secs, 4344 KB]
   Test 4: TEST OK [0.000 secs, 4344 KB]
   Test 5: TEST OK [0.000 secs, 4344 KB]
   Test 6: TEST OK [0.000 secs, 4344 KB]
   Test 7: TEST OK [0.000 secs, 4344 KB]
   Test 8: TEST OK [0.000 secs, 4344 KB]
   Test 9: TEST OK [0.000 secs, 4344 KB]

All tests OK.
YOUR PROGRAM ('stall4') WORKED FIRST TIME!  That's fantastic
-- and a rare thing.  Please accept these special automated
congratulations.
*/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值