ASCII

Problem Description
Since all we know the ASCII code, your job is simple: input numbers and output corresponding messages.
 
Input
The first line contains one integer T (1<=T<=1000).
The input will contain T positive integers separated by whitespaces (spaces, newlines, TABs).
The integers will be no less than 32.
 
Output
Output the corresponding message in just one line.
Warning: no extra characters are allowed.
 
Sample Input
13
72 101 108 108 111 44
32 119 111 114 108 100 33
 
Sample Output
Hello, world!
 
 
Source
“光庭杯”第五届华中北区程序设计邀请赛 暨 WHU第八届程序设计竞赛
 
Recommend
lcy
题目分析
输入字符的ASCII,输出字符,要求不能多输出字符
解题思路
用int类型的保存,然后转化成char类型,输出就行
源代码
#include<iostream>
#include<string>
#include<algorithm>
#include<vector>
//#include<bits\stdc++.h>
using namespace std;
int main()
{
   int a[1001];
   char b[1001];
   int t,i;
   cin>>t;
   for(i=0;i<t;i++)
    cin>>a[i];
   for(i=0;i<t;i++)
   {
     b[i]=a[i];
    cout<<b[i];
   }
   return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值