POJ1316 Milking Time

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

* Line 1: Three space-separated integers: NM, and R
* Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the Nhours

Sample Input
12 4 2
1 2 8
10 12 19
3 6 24
7 10 31
Sample Output

43

解题思路

这题的难度我感觉在于要如何规划好工作时间。我的思路是先将工作开始的时间先从小到大排序一波,然后再去对牛奶数量进行dp,转移方程为dp[i] = max(dp[i],dp[j] + a[i].value); ,要注意下一个的开始时间要大于上一个的结束时间加上休息时间

#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
struct node{
	int start,end,value;
}a[1005];
int dp[1005];
bool cmp(node a,node b){
	return a.start < b.start;
}
int main(){
	int n,m,r;
	int maxx;
	while(cin>>n>>m>>r){
		memset(dp,0,sizeof(dp));
		for(int i = 0;i < m;i++){
			cin>>a[i].start>>a[i].end>>a[i].value;
		}
		sort(a,a + m,cmp);
		maxx = 0;
		for(int i = 0;i < m;i++){
			dp[i] = a[i].value;
			for(int j = i;j >= 0;j--){
				if(a[i].start >= a[j].end + r){
					dp[i] = max(dp[i],dp[j] + a[i].value); 
				}
			}
		}
		for(int i = 0;i < m;i++){
			maxx = max(maxx,dp[i]);
		}
		cout<<maxx<<endl;
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值