《ACM程序设计》书中题目―L

Description
In most languages, text is written from left to right. However, there are other languages where text is read and written from right to left. As a first step towards a program that automatically translates from a left-to-right language into a right-to-left language and back, you are to write a program that changes the direction of a given text.

Input Specification

The input contains several test cases. The first line contains an integer specifying the number of test cases. Each test case consists of a single line of text which contains at most 70 characters. However, the newline character at the end of each line is not considered to be part of the line.

Output Specification
For each test case, print a line containing the characters of the input line in reverse order.

Sample Input
3
Frankly, I don't think we'll make much
money out of this scheme.
madam I'm adam

Sample Output

hcum ekam ll'ew kniht t'nod I ,ylknarF
.emehcs siht fo tuo yenom
mada m'I madam

1、题意:让你输入一段字符(包括空格)然后下再倒序输出。
2、思路:使用cin.getline()实现输入包括空格的字符串并在回车后结束输入,使用reverse函数实现倒序输出。
3、代码:
#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
int main()
{
int n=0,t,j;
char a[100];
string b;
while(cin.getline(a,80))
{
if(n==0)
n=1;
else
{
b=a;
reverse(b.begin(),b.end());
cout<<b<<endl;
}
}
return 0;
}
4、总结:学会了使用cin.getline(),并且因为读入了第一行的整数而PE了好多次,也学习了reverse的用法。


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值