ACM程序设计 书中题目L

Description

In most languages, text is written from left to right. However, there are other languages where text is read and written from right to left. As a first step towards a program that automatically translates from a left-to-right language into a right-to-left language and back, you are to write a program that changes the direction of a given text.


Input Specification

The input contains several test cases. The first line contains an integer specifying the number of test cases. Each test case consists of a single line of text which contains at most 70 characters. However, the newline character at the end of each line is not considered to be part of the line.


Output Specification

For each test case, print a line containing the characters of the input line in reverse order.


Sample Input

3
Frankly, I don't think we'll make much
money out of this scheme.
madam I'm adam


Sample Output

hcum ekam ll'ew kniht t'nod I ,ylknarF
.emehcs siht fo tuo yenom

mada m'I madam

简单地说就是字符串倒序输出,嘛,没什么难度,需要注意的是,输入完数字使要用一个字符把回车接收掉,不然第一次循环gets()会接收回车,就会少一次啦。

#include<bits/stdc++.h>  
using namespace std;  
int main()  
{  
        int i,j,n,l;  
        char a[100],b;  
        cin>>n;  
        cin.get(b);  
        for(i=0;i<n;i++)  
        {  
                gets(a);  
                for(i=0;i<100;i++)
			if(a[i]=='\0')
			{
				l=i;
				break;
			} 		//这一部分可以直接用l=strlen(a)代替
                for(j=l-1;j>=0;j--)  
                        cout<<a[j];  
                cout<<endl;  
        }  
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值