Description
Input Specification
The input contains several test cases. The first line contains an integer specifying the number of test cases. Each test case consists of a single line of text which contains at most 70 characters. However, the newline character at the end of each line is not considered to be part of the line.
Output Specification
For each test case, print a line containing the characters of the input line in reverse order.
Sample Input
3
Frankly, I don't think we'll make much
money out of this scheme.
madam I'm adam
Sample Output
hcum ekam ll'ew kniht t'nod I ,ylknarF
.emehcs siht fo tuo yenom
mada m'I madam
把输入的句子一个单词一个单词的反过来输出
分析:
可以用到stack把输入的字母按照相反顺序输出
最重要的是把回车吃了
感受:
我在吃回车的时候浪费太多时间了 以后要记住每种输入的方法
#include<bits/stdc++.h>
using namespace std;
int main()
{
int n,i,t,l;
char h[100],c;
stack<char>s;
cin>>n;
cin.get(c); //吃掉回车
for(i=0;i<n;i++)
{
gets(h);
t=strlen(h);
for(l=0;l<t;l++)
{
s.push(h[l]);
}
while(t>0)
{
cout<<s.top();
s.pop();
t--;
}
if(i<n-1)
cout<<endl;
}
}