L

Description

In most languages, text is written from left to right. However, there are other languages where text is read and written from right to left. As a first step towards a program that automatically translates from a left-to-right language into a right-to-left language and back, you are to write a program that changes the direction of a given text.


Input Specification

The input contains several test cases. The first line contains an integer specifying the number of test cases. Each test case consists of a single line of text which contains at most 70 characters. However, the newline character at the end of each line is not considered to be part of the line.


Output Specification

For each test case, print a line containing the characters of the input line in reverse order.


Sample Input

3
Frankly, I don't think we'll make much
money out of this scheme.
madam I'm adam


Sample Output

hcum ekam ll'ew kniht t'nod I ,ylknarF
.emehcs siht fo tuo yenom
mada m'I madam

题意:

把输入的句子一个单词一个单词的反过来输出

分析:

可以用到stack把输入的字母按照相反顺序输出

 最重要的是把回车吃了

感受:

我在吃回车的时候浪费太多时间了 快哭了以后要记住每种输入的方法

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int n,i,t,l;
    char h[100],c;
    stack<char>s;
    cin>>n;
    cin.get(c); //吃掉回车
    for(i=0;i<n;i++)
    {
        gets(h);
        t=strlen(h);
        for(l=0;l<t;l++)
        {
            s.push(h[l]);
        }
        while(t>0)
        {
            cout<<s.top();
            s.pop();
            t--;
        }
        if(i<n-1)
            cout<<endl;
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值