UVA 10003--Cutting Sticks(区间dp)

You have to cut a wood stick into pieces. The most affordable company, The Analog Cutting Machinery,

Inc. (ACM), charges money according to the length of the stick being cut. Their procedure of work
requires that they only make one cut at a time.
It is easy to notice that different selections in the order of cutting can led to different prices. For
example, consider a stick of length 10 meters that has to be cut at 2, 4 and 7 meters from one end.
There are several choices. One can be cutting first at 2, then at 4, then at 7. This leads to a price
of 10 + 8 + 6 = 24 because the first stick was of 10 meters, the resulting of 8 and the last one of 6.
Another choice could be cutting at 4, then at 2, then at 7. This would lead to a price of 10 + 4 + 6 =
20, which is a better price.
Your boss trusts your computer abilities to find out the minimum cost for cutting a given stick.
Input
The input will consist of several input cases. The first line of each test case will contain a positive
number l that represents the length of the stick to be cut. You can assume l < 1000. The next line will
contain the number n (n < 50) of cuts to be made.
The next line consists of n positive numbers ci (0 < ci < l) representing the places where the cuts
have to be done, given in strictly increasing order.
An input case with l = 0 will represent the end of the input.
Output
You have to print the cost of the optimal solution of the cutting problem, that is the minimum cost of
cutting the given stick. Format the output as shown below.
Sample Input
100
3
25 50 75
10
4
4 5 7 8
0
Sample Output
The minimum cutting is 200.
The minimum cutting is 22
题意:将s长度的木板,在n个位置切开,每次切割花费是当前木板长度,求最小花费
思路:标准的区间dp,也很明显,
感想:递推关系公式还是比较好推的,但是很久没做了,就先看了看模板~还好是个水题,直接套模板就可以~
代码:
#include<bits/stdc++.h>
using namespace std;
#define inf 0x3f3f3f3f
#define mod 1000000007
int n,ans,s,dp[1005][1005],num[1005],pos[10005];
int main()
{
    while(~scanf("%d",&s))
    {
        if(s==0) break;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&pos[i]);
        }
        pos[n+1]=s;
        for(int i=2;i<=n+1;i++)
        {
             for(int j=0;j<=n-i+1;j++)
             {
                 int l=j+i;
                 dp[j][l]=0x3f3f3f3f;
                 for(int k=j+1;k<l;k++)
                 {
                     dp[j][l]=min(dp[j][l],dp[j][k]+dp[k][l]+pos[l]-pos[j]);
                     //cout<<dp[j][l]<<endl;
                 }
             }
        }
        printf("The minimum cutting is %d.\n",dp[0][n+1]);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值