1031 Hello World for U (20分)——C/C++(字符串处理)

博客围绕将给定字符串转换为U型输出展开。先给出题目要求,即满足n2 >= n1 == n3和n1 + n2 + n3 = N + 2(N为字符串长度)。接着分析思路,分n % 3是否为0两种情况确定n1、n2、n3的值,最后给出AC代码。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, “helloworld” can be printed as:
h d
e l
l r
lowo
That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible — that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 – 2 = N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

题目大意:

给定一个字符串,输出漂亮的“U”型,左侧从上到下为n1,底部从最左边到最右边为n2,右侧从最下边到最上面为n3;并且要满足n2 >= n1 == n3n1 + n2 + n3 = N + 2,其中N为输入的字符串的长度。

思路及分析:

首先分情况讨论:设n = N + 2;即n1 + n2 + n3 = n;

  1. 当n % 3 == 0 时,n1 = n2 = n3 = n / 3;
  2. 当n % 3 != 0 时,n1 = n3 = n / 3,n2 = n / 3 + n % 3。

找到n1,n2的值后循环输出U型格式(具体看代码)。

AC代码:

#include<iostream>
#include<string>

using namespace std;

int main(){
	int n1, n2;
	string s;
	cin >> s;
	int n = s.length() + 2;
	n1 = n / 3;
	n2 = n / 3 + n % 3;
	for(int i = 0; i < n1-1; i++){
		cout << s[i];
		for(int j = 0; j < n2-2; j++){
			cout << ' ';
		}
		cout << s[s.length()-i-1] << endl;
	}
	for(int i = n1-1; i < s.length()-n1+1; i++){
		cout << s[i];
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

21岁被迫秃头

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值