PAT-A 1005 Spell It Right (20 分)

1005 Spell It Right (20 分)

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (≤10​100​​).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

思路:还是使用sprintf将和转换为字符串的形式。

#include <cstdio>
#include <cstring>

int main()
{
    char in[101];
    scanf("%s", in);

    int sum = 0;
    for(int i = 0; i < strlen(in); i++)
        sum += in[i] - '0';//计算各位的和

    char s_sum[4];//位数最多为100,和最大为900,4位足够
    sprintf(s_sum, "%d", sum);//将和转换为字符串的形式

    char* digit[10] = {"zero", "one", "two", "three", "four", "five", "six", "seven", "eight", "nine"};
    for(int i = 0; i < strlen(s_sum); i++)
    {
        int index = s_sum[i] - '0';//计算和的各位数字
        printf("%s", digit[index]);//输出和的各位数字的英文形式
        if(i != strlen(s_sum) - 1)
            printf(" ");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值