POJ-3278 Catch That Cow (BFS入门题



Catch That Cow

Time Limit: 2000MS


Memory Limit: 65536K

Total Submissions: 93780


Accepted: 29419

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source

USACO 2007 Open Silver



分析:bfs入门题如果前面的数比后面的数大,那么只能后退,直接输出两者之差。一般情况下,我们用搜索直接解决,每一步三个操作,搜出答案即可。注意点见注释。

#include <iostream>
#include<stdio.h>
#include<queue>
#include<string.h>

using namespace std;

const int SIZE=100005;

int step[3*SIZE]; //防止数组越界的保险,正常没有3也可以
int check[3*SIZE];

void bfs(int s,int e)
{
    queue<int> q;
    while(!q.empty()) q.pop();
    q.push(s);
    step[s]=0;
    check[s]=1;

    while(!q.empty())
    {
        int now=q.front();
        if(now==e) break;
        q.pop();

        if(!check[now+1]&&now+1<=100000)
        {
            q.push(now+1);
            step[now+1]=step[now]+1;
            check[now+1]=1; //这个地方我觉得是BFS最需要注意的,如果写在最上方的话,后面就会有一些情况第二次进入队列在步数上第二次计算就会有问题。
        }


        if(!check[now-1]&&now-1>=0)
        {
            q.push(now-1);
            step[now-1]=step[now]+1;
            check[now-1]=1;
        }



        if(!check[now*2]&&now*2<=100000)
        {
            q.push(now*2);
            step[now*2]=step[now]+1;
            check[now*2]=1;
        }

    }


}

int main()
{
    int m,n;

    while(cin>>m>>n)
    {
        if(m>=n)
        {
            cout<<m-n<<endl;
            continue;
        }
        memset(step,0,sizeof(step));
        memset(check,0,sizeof(check));

        bfs(m,n);
        cout<<step[n]<<endl;
    }


    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值