字符串判定字符

案例1 输入一个字符串(可包含空格)统计组成字符串各类型的个数,并输出所有特殊字符。

[样例输入]
abSD F12¥#% v

[样例输出]
¥ # %
大写:3
小写:3
数字:2
空格:2
C++代码:

#include<iostream>
using namespace std;
int main(){
	char a[20];
	int k=0,d=0,x=0,s=0,i=0;
	gets(a);
	while(a[i]!='\0'){
		if(a[i]>='A' and a[i]<='Z'){
			d+=1;
		}else if(a[i]>='a' and a[i]<='z'){
			x+=1;
		}else if(a[i]>='0' and a[i]<='9'){
			s+=1;
		}else if(a[i]==' '){
			k+=1;
		}else{
			cout<<a[i]<<" ";
		}
		i++;
	}
	cout<<endl;
	cout<<"大写:"<<d<<endl;
	cout<<"小写:"<<x<<endl;
	cout<<"数字:"<<s<<endl;
	cout<<"空格:"<<k<<endl;
	return 0;
}

python代码:

inp = input()
d=0;x=0;s=0;k=0
for c in inp:
    if c.isupper():
        d+=1
    elif c.islower():
        x+=1
    elif c.isdigit():
        s+=1
    elif c==' ':
        k+=1
    else:
        print(c+' ',end='')
print()
print("大写:"+str(d))
print("小写:"+str(x))
print("数字:"+str(s))
print("空格:"+str(k))

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ChenWenKen

你的鼓励是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值