PAT 1023 Have Fun with Numbers

15 篇文章 0 订阅

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798
#include<iostream>
#include<string>
#include<sstream>
#include<vector>
#include<algorithm>
#include<cmath>
using namespace std;
//9:38

int main()
{
	//freopen("C:\\Users\\chenzhuo\\Desktop\\in.txt","r",stdin);
	
	vector<int> tmp(10,0);
	vector<int> tmp1(10,0);
	string str1;
	cin>>str1;
	for(int i=0;i<str1.size();i++)
	{
		tmp[str1[i]-'0']++;
	}
	int jin=0;
	string str2="";
	for(int i=str1.size()-1;i>=0;i--)
	{
		int k=2*(str1[i]-'0')+jin;
		jin=0;
		if(k>=10)
		{
			k-=10;jin=1;
		}
		char c=k+'0';
		str2=c+str2;
	}
	if(jin==1)
	{
		str2='1'+str2;
	}
	for(int i=0;i<str2.size();i++)
	{
		tmp[str2[i]-'0']--;
	}
	if(tmp==tmp1) 
		cout<<"Yes"<<endl;
	else cout<<"No"<<endl;
	
	for(int i=0;i<str2.size();i++)
	{
		cout<<str2[i];
	}
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值