1125. Chain the Ropes (25)

1125. Chain the Ropes (25)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given some segments of rope, you are supposed to chain them into one rope. Each time you may only fold two segments into loops and chain them into one piece, as shown by the figure. The resulting chain will be treated as another segment of rope and can be folded again. After each chaining, the lengths of the original two segments will be halved.

Your job is to make the longest possible rope out of N given segments.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (2 <= N <= 104). Then N positive integer lengths of the segments are given in the next line, separated by spaces. All the integers are no more than 104.

Output Specification:

For each case, print in a line the length of the longest possible rope that can be made by the given segments. The result must be rounded to the nearest integer that is no greater than the maximum length.

Sample Input:
8
10 15 12 3 4 13 1 15
Sample Output:
14
题意:给出N段绳子,每次你可以任意选两端进行合并,合并后的绳子去对折的长度加入集合,重复操作直至只有一条。要求输出最长的一种情况。

思路:很明显想要最长的,得要让小的先进入合并,大的放最后,所以开始时我选择了qsort(),然而测试点挂了一片……

           冥思苦想下发现,并入的节点可能比排序后数组最小的那一个要大,但是显然不能每次都排序(其实因为有序,用二分查找也是可以的)

           这时候当然选择我们的排序利器,set啦!

           因为有重复的数值,所以声明用multiset

           同样因为有重复的数值,erase(a),这种是不可取的,它会把一次把所有相同的元素都删除

           set begin(),返回的是迭代器,所以用 * 返回迭代器所指的元素

代码:

#include<iostream>
#include<algorithm>
#include<set>
using namespace std;
int main()
{
	int n, tmp;
	cin >> n;
	multiset<int> num;
	for (int i = 0; i < n; i++)
	{
		cin >> tmp;
		num.insert(tmp);
	}
	while (num.size() >= 2)
	{
		int a = *num.begin(); num.erase(num.begin());
		int b = *num.begin(); num.erase(num.begin());
		num.insert((a + b) / 2);
	}
	cout << *num.begin() << endl;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值