The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker’s personality. Such a preference is called “Kuchiguse” and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle “nyan~” is often used as a stereotype for characters with a cat-like personality:
Itai nyan~ (It hurts, nyan~)
Ninjin wa iyada nyan~ (I hate carrots, nyan~)
Now given a few lines spoken by the same character, can you find her Kuchiguse?
Input Specification:
Each input file contains one test case. For each case, the first line is an integer N (2<=N<=100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character’s spoken line. The spoken lines are case sensitive.
Output Specification:
For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write “nai”.
Sample Input 1:
3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~
Sample Output 1:
nyan~
Sample Input 2:
3
Itai!
Ninjinnwaiyada T_T
T_T
Sample Output 2:
nai
suffix!表示后缀
3
aaa
aaa
aaa
out:aaa
看代码吧 比较简单的模拟题 c++字符串很好用哦
#include <bits/stdc++.h>
using namespace std;
string str[200];
int main(){
int n;
cin>>n;
getchar();
for(int i=1;i<=n;i++){
getline(cin,str[i]);
reverse(str[i].begin(),str[i].end());
}
string ans;
for(int k=0;k<str[1].size();k++){
char ch=str[1][k];
int flag=1;
for(int i=2;i<=n;i++){
if(str[i][k]!=ch){
flag=0;
break;
}
}
if(flag){
ans+=ch;
}
else break;
}
if(ans.size()==0){
printf("nai\n");
}
else{
reverse(ans.begin(),ans.end());
cout<<ans<<endl;
}
return 0;
}