PAT 甲级 1001 A+B Format (20 分)

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

先进行读题,题目的意思还是可以理解的,意为求出a+b的值,然后每隔三位加上一个逗号。一开始由于新学了一个sprintf(),就想试一试,可以将数字转换为字符数组,后选择直接用最熟悉的vector进行上手。先建立一个<char>类型的容器记录为s,选择了s后下一步便是将数字转换为字符添加入容器s之中。注意添加的语句是push_back相当于添加的顺序是反的,最后还需要利用reverse(s.begin(),s.end()函数对s进行翻转。最后根据正负号添加上符号。

在添加完毕符号后,下一步便要开始添加逗号,在将每一位数字转换为字符添加入s的过程中,利用一个变量起名为count,用count来统计数字的位数,由0开始,到3便添加一个逗号,同时赋值为0而重新开始统计。

需要注意的两点有:1.会出现数字位数是3的倍数,此时第一位会添加上逗号,要增加判断条件;2.如果是相反数相加要做单独处理。

完整代码如下:

#include <bits/stdc++.h>

using namespace std;



int main()
{
    int a,b;
    cin>>a>>b;
    char d;
    int c;
    c=a+b;
    vector <char> s;
    int count=0;
    while(c!=0)
    {
        d='0'+(abs(c)%10);
        count++;
        s.push_back(d);
        if(count==3&&(c/10!=0))
        {
            s.push_back(',');
            count=0;
        }
        c=c/10;
    }
    if(a+b<0)
    {
        s.push_back('-');
    }
    reverse(s.begin(),s.end());
    int i=0;
    if(a+b!=0)
    {
        for(i;i<s.size();i++)
    {
        cout<<s[i];
    }
    }
    else if(a+b==0)
    {
        cout<<0<<endl;
    }
    return 0;
}

 

------------------------------------------------------- 我是分割线 2020 1.21------------------------------------------------------------------------

 

 

 

 

2020的代码如下:

#include <bits/stdc++.h>

using namespace std;

vector<char> s;
int main()
{
    int a,b;
    cin>>a>>b;
    int c;
    c=abs(a+b);
    int count = 0;
    if(c==0)
    {
        cout<<0<<endl;
    }
    else
    {
            while(c!=0)
        {
            char d = (char)('0'+c%10);
            s.push_back(d);
            count++;
            if(count==3&& c/10!=0)
            {
                s.push_back(',');
                count =0;
            }
            c=c/10;
        }
        if(a+b<0)
        {
            s.push_back('-');
        }
        reverse(s.begin(),s.end());
        for(vector<char>::iterator it=s.begin();it!=s.end();it++)
        {
            cout<<*it; //vector 输出容器中的值相当于输出指针值
        }
    }

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值