PAT A1020 Tree Traversals

1020 Tree Traversals

分数 25

作者 CHEN, Yue

单位 浙江大学

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

 

记得一定要为指针分配空间,否则会出现段错误,谨记!

详细解释请前往另一篇博客:

给定中序遍历和另外一种遍历方法确定一棵二叉树_疯疯癫癫才自由的博客-CSDN博客_怎么通过中序遍历和后序遍历确定一棵树

#include <iostream>
#include <cstring>
#include <algorithm>
#include <queue>

using namespace std;

typedef struct TNode* Bin;

struct TNode
{
    int data;
    Bin l,r;
};

const int N = 30;
int beh[N], mid[N];
int flag = 1;

Bin get_tree(int behL, int behR, int midL, int midR)
{
    if(behL > behR) //递归边界
        return NULL;
        
    //记得一定要为指针分配空间,否则会出现SF错误,谨记!
    Bin u = new TNode;
    
    int v = beh[behR];
    int k = 0;
    for(int i=midL; i<=midR; ++i)
        if(mid[i] == v)
        {
            k = i;
            break;
        }
        
    int lenL = k - midL; //左子树的节点数目
    u->data = v;
    
    //递归左边界
    u -> l = get_tree(behL, behL+lenL-1, midL, k-1);
    
    //递归右边界
    u -> r = get_tree(behL+lenL, behR-1, k+1, midR);
    
    return u;
}

void level_traver(Bin root)
{
    queue<Bin> q;
    q.push(root);
    
    while(q.size())
    {
        Bin top = q.front();
        q.pop();
        if(flag)
            flag = 0;
        else
            cout << ' ';
        cout << top->data;
        if(top -> l)
            q.push(top -> l);
        if(top -> r)
            q.push(top -> r);
    }
}

int main()
{
    int n;
    cin >> n;
    
    for(int i=0; i<n; ++i)
        cin >> beh[i];
    for(int i=0; i<n; ++i)
        cin >> mid[i];
    
    Bin root = NULL;
    root = get_tree(0, n-1, 0, n-1);
    
    level_traver(root);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值