关于Ubuntu的Unable to locate package无法更新源问题解决方案

致谢:关于Ubuntu的Unable to locate package无法更新源问题解决方案

最近使用Ubuntu进行科学实验,开始使用时发现sudo apt-get stall  [软件名],总是提示如下:

依据网上所说的更新 apt-get install update也没有作用。

后来查阅发现是源的问题,官方的软件源网址在国内下载太慢,于是就决定使用重新设置更新软件源的方式。经过测试,可以使用两种方式;

方式一:图形界面设置

打开系统设置,如下,选择进入其中的 Software&Update。

进入后,会看到如下视图:

选择Download From的下拉列表,选择其中的others,国内的选择China,从:

选择其中合适的源服务器,点击Choose Server:

提示输入密码,就是你的账号密码,输入后,点击Authenticate。点击主页面的close,弹出对话框:

点击Reload,即系统会自动更新源。

 

方式2:手动更新源列表文件

Ubuntu中下载更新软件时,会从 /etc/apt/source.list源文件中设置的网址下载更新源文件,所以,出现问题也是该源列表文件出现的问题,做法如下:

首先:备份你的源列表文件,这样做是防止我们手动编辑出现错误还可以恢复到原来的系统源列表文件:

sudo   cp /etc/apt/sources.list     /etc/apt/sources.list_backup

其次,而后用gedit或其他编辑器打开:


gedit /etc/apt/sources.list

 

最后,选择对应的源编辑更新源列表文件。

不同的个人,企业,单位可根据实际情况选择如下的源进行更新编辑,地址如下:

http://wiki.ubuntu.org.cn/%E6%BA%90%E5%88%97%E8%A1%A8

 

无论采用方法一或者方法二,所以工作做完后,都必须在终端输入:

sudo  apt-get  update 进行更新操作,

然后就可以进行各种sudo  apt-get  install  <软件名>操作了。

如上:成功解决Ubuntu的Unable to locate package无法更新源问题。

 

阅读更多
换一批

没有更多推荐了,返回首页