PAT 1021 Deepest Root (25 分) -甲级

1021 Deepest Root (25 分)

A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤104) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N−1 lines follow, each describes an edge by given the two adjacent nodes’ numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print Error: K components where K is the number of connected components in the graph.

Sample Input 1:

5
1 2
1 3
1 4
2 5

Sample Output 1:

3
4
5

Sample Input 2:

5
1 3
1 4
2 5
3 4

Sample Output 2:

Error: 2 components
#include <stdio.h>
#include <set>
#include <algorithm>
#include <vector>

using namespace std;
vector<int> Adj[10010];
set<int> temp, ans;
int vis[10010] = {0};
int N, counts = 0;
int maxDepth = 0;

void DFS(int v, int depth) {
    vis[v] = 1;
    depth++;
    if (maxDepth < depth) {
        maxDepth = depth;
        temp.clear();
    }
    if (maxDepth == depth)
        temp.insert(v);
    for (int i = 0; i < Adj[v].size(); ++i) {
        if (vis[Adj[v][i]] == 0) {
            DFS(Adj[v][i], depth);
        }
    }
}

void DFSTrave() {
    for (int i = 1; i <= N; ++i) {
        if (vis[i] == 0) {
            DFS(i, 0);
            counts++;
        }
    }
}

int main() {
    scanf("%d", &N);
    for (int i = 0; i < N - 1; ++i) {
        int a, b;
        scanf("%d%d", &a, &b);
        Adj[a].push_back(b);
        Adj[b].push_back(a);
    }
    DFSTrave();
    ans = temp;
    fill(vis, vis + N + 1, 0);
    DFS(*ans.begin(), 0);
    ans.insert(temp.begin(), temp.end());
    if (counts > 1) {
        printf("Error: %d components\n", counts);
    } else {
        for (set<int>::iterator it = ans.begin(); it != ans.end(); it++) {
            printf("%d\n", *it);
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值