切木棒(贪心&&优先队列)

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer  N, the number of planks 
Lines 2.. N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make  N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

大意:

需要把一根长木棍锯成一些短木棍

短木棍的长度是告诉你的

每一次锯的花费为要锯的改段的长度

问最小花费

比如n个小木棍长度分别5 8 8

也就是相当于你有一根21的木棍  现在需要把它锯成 上述的三段

每次只能把一个木棍锯成两段

比如21可以锯成13 和 8   但是由于选择的是21  所以花费为21

第二次把13 锯成5和8  花费 为13

总花费为21 + 13 = 34

相关链接(http://blog.csdn.net/chengyingzhilian/article/details/8078032

            (Java优先队列

C语言AC结果:

时间语言结果内存
16MSCAccepted248K

#include<stdio.h>
__int64 sum;
int b[20005];
int h,len;
pt(int i)
{
	return i/2;
}
lt(int i)
{
	return 2*i;
}
rt(int i)
{
	return 2*i+1;
}
mh(int i)
{
	int l,r,lg,t;
	l=lt(i);
	r=rt(i);
	if(l<=h&&b[l]<b[i])
		lg=l;
	else
		lg=i;
	if(r<=h&&b[r]<b[lg])
		lg=r;
	if(lg!=i)
	{
		t=b[i];
		b[i]=b[lg];
		b[lg]=t;
		mh(lg);
	}
}
bmh()
{
	int i;
	h=len;
	for(i=len/2;i>0;i--)
		mh(i);
}
int hem()
{
	int min=b[1];
	b[1]=b[h];
	h--;
	mh(1);
	return min;
}
hink(int i,int key)
{
	int t;
	b[i]=key;
	mh(1);
}		
int main()
{
	int n,i,j,t;
	while(scanf("%d",&n)!=EOF) 
		{
		sum=0;
		for(i=1;i<=n;i++)
			scanf("%d",&b[i]);
		len=n;
		bmh();
		while(h>1)
		{
			t=hem();
			t+=b[1];
			sum+=t;
			hink(1,t);
		}
			
		printf("%I64d\n",sum);
		}
return 0;
}

JAVA语言:

时间语言结果内存
1750MSJAVAAccepted5616K


import java.util.*;
public class Main {

	public static void main(String[] args) {
		Scanner s = new Scanner(System.in);

//              创建优先队列,找百度
		PriorityQueue<Long> pq = new PriorityQueue<Long>();

//              输入数据
		int N = s.nextInt();
		for(int i = 0; i < N; i++)
			pq.add(s.nextLong());
		
//              首先把最小的两段木头拼在一起后算在cost里,这就是最后一刀的最优解。
//              然后把拼接后的木段放入优先队列中,重复第一步
//              直到优先队列中只剩下最后一个数字。
		long cost = 0;
		while(N > 1){
			long c = pq.poll() + pq.poll();
			cost += c;
			pq.add(c);
			N--;
		}
		System.out.println(cost);
	}
}

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值