The Suspects
Time Limit: 1000MS Memory Limit: 20000K
Description
Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output
4
1
1
Source
http://poj.org/problem?id=1611
代码实现1(me):
#include <stdio.h>
#include <stdlib.h>
int pre[30010];
int rank[30010];
int member[30010];//组内成员编号
int find(int x)
{
int r;
int k;
int j;
r=x;
while(r!=pre[r])
r = pre[r];
k=x;
while(k!=r)
{
j=pre[k];
pre[k]=r;
k = j;
}
return r;
}
void merge(int x,int y)
{
x=find(x);
y=find(y);
if(x==y)
return;
if(rank[x]<rank[y])
pre[x]=y;
else
{
pre[y]=x;
if(rank[x]==rank[y])
rank[x]++;
}
}
int main()
{
int m,n;
while(1)
{
scanf("%d %d",&n,&m);//n是学生数量,m是组的数量
if(m==0&&n==0)
break;
int i,j;
for(i=0; i<n; i++)
{
pre[i]=i;//初始化每个结点祖先是自己
rank[i]=0;//初始化树的高度为0
}
rank[0]=10000000;
int k;//组内学生数量
for(i=0; i<m; i++)
{
scanf("%d",&k);
for(j=0; j<k; j++)
{
scanf("%d",&member[j]);
}
int judge = 0;
for(j=0; j<k; j++)
{
if(member[j]==0)
{
for(j=0; j<k; j++)
{
merge(0,member[j]);
}
judge = 1;
break;
}
}
if(judge==0)
{
for(j=0; j<k; j++)
{
if(j!=0)
{
merge(member[j-1],member[j]);
}
}
}
}
int sum=0;
for(j=0;j<n;j++)
merge(j,j);
for(i=0; i<n; i++)
{
if(pre[i]==0)
sum++;
}
printf("%d\n",sum);
}
return 0;
}
代码实现2:
#include <stdio.h>
int pre[30010];
int rank[30010];
int find(int x) //递归方式
{
//查找元素x所在的集合,同时压缩寻找所经过的路径
//函数运行完后的效果是所经过的结点都指向x所找到的祖先
if(x != pre[x])
pre[x] = find(pre[x]);
return pre[x];
}
void merge(int x, int y)
{
/*将两个集合的元素合并成一个集合*/
x = find(x); //查找x所在的集合
y = find(y); //查找y所在的集合
if(x == y)
return; //如果x和y在同一个集合中则不需要合并
/*按秩合并:将秩小的合并到大的集合中(即将矮的树合并到高的树)*/
if(rank[x] < rank[y])
pre[x] = y;
else{
pre[y] = x;
if(rank[x] == rank[y])
rank[x]++;
}
}
int main()
{
int n; //n为点的个数
int m; //m为边的个数
int i,j,k;
int s[30010];
while(1)
{
scanf("%d", &n);
if(n == 0)
break;
scanf("%d", &m);
for(int i = 0; i <= n; i++){
/*将要用到的数组初始化*/
pre[i] = i; //初始时每个结点的祖先是自己
rank[i] = 0; //初始时树的高度为0
}
for(int i = 0; i < m; i++){
scanf("%d", &k);
for(j = 0; j < k; j++){
scanf("%d", s+j);
}
for(j = 1; j < k; j++)
merge(s[j-1], s[j]);
}
int sum = 0;
for(int i = 0; i < n; i++){
if(find(i) == find(0))
sum++;
}
printf("%d\n", sum);
}
return 0;
}