[图解] 数组模拟Trie树

该程序实现了一个基于Trie树的数据结构,用于高效地插入字符串并查询是否存在。通过读取输入的指令,程序能够动态维护Trie树,并输出查询结果。Trie树是一种常见的字符串检索数据结构,对于大量字符串的快速查找非常有用。
摘要由CSDN通过智能技术生成

输入样例:

5
I abc
Q abc
Q ab
I ab
Q ab

输出样例:

1
0
1

 

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;

const int N = 2e4+10;
int son[N][26],cnt[N],idx;
char str[N];

void Insert(char c[])
{
    int level = 0;
    for (int i = 0; c[i]; i ++ )//到'\0'停止
    {
        int u = c[i]-'a';
        if(!son[level][u]) son[level][u] = ++idx;//注意son[N][26]中,每层只存一个
        level = son[level][u];//模拟树的向下递归
    }
    cnt[level]++;//全部插入,叶节点增加,表示以当前前缀结尾的字符串数量
}

int Query(char c[])//与Insert()同理
{
    int level = 0;
    for (int i = 0; c[i]; i ++ )
    {
        int u = c[i]-'a';
        if(!son[level][u]) return 0;
        level = son[level][u];
    }
    return cnt[level];
}

int main()
{
    int n;
    char op;
    cin >> n;

    while (n -- )
    {
        scanf(" %c%s", &op, str);
        if(op == 'I'){
            Insert(str);
        }else if(op == 'Q'){
            cout << Query(str) << endl;
        }
    }
    return 0;
}

以下是使用数组模拟trie的C语言代码: ```c #include <stdio.h> #include <stdlib.h> #include <string.h> #define TRIE_SIZE 26 typedef struct TrieNode { int is_end; struct TrieNode *next[TRIE_SIZE]; } TrieNode; TrieNode *create_node() { TrieNode *node = (TrieNode *) malloc(sizeof(TrieNode)); node->is_end = 0; for (int i = 0; i < TRIE_SIZE; i++) { node->next[i] = NULL; } return node; } void insert(TrieNode *root, char *word) { TrieNode *node = root; int len = strlen(word); for (int i = 0; i < len; i++) { int index = word[i] - 'a'; if (node->next[index] == NULL) { node->next[index] = create_node(); } node = node->next[index]; } node->is_end = 1; } int search(TrieNode *root, char *word) { TrieNode *node = root; int len = strlen(word); for (int i = 0; i < len; i++) { int index = word[i] - 'a'; if (node->next[index] == NULL) { return 0; } node = node->next[index]; } return node->is_end; } int main() { char *words[] = {"apple", "banana", "orange", "grape", "watermelon"}; TrieNode *root = create_node(); for (int i = 0; i < 5; i++) { insert(root, words[i]); } printf("%d\n", search(root, "apple")); printf("%d\n", search(root, "watermelon")); printf("%d\n", search(root, "peach")); return 0; } ``` 在上述代码中,每个节点都有一个 `next` 数组,用于保存下一个字符对应的节点指针。在插入和查找时,遍历输入的字符串,根据每个字符找到对应的节点,如果节点不存在则创建新的节点。最后一个节点标记为单词结尾。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

泥烟

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值