Idea报错:请使用 -source 7 或更高版本以启用 diamond 运算符

解决思路:

1.检查ide的默认编译环境 ,快捷键ctrl + alt +s

找Java Compiler ,发现设置是 Target bytencode version 是1.6 改成1.7 

 

发现还是报错。

2.检查项目的SDK选择和项目语言level 都改成1.7 和7

发现还是报错

3.检查项目的 Modules 中的language level 改成 7 

发现还是报错

4.检查maven的compile plugin 插件 由1.6改成1.7

成功。

相关推荐
©️2020 CSDN 皮肤主题: 编程工作室 设计师:CSDN官方博客 返回首页