B1054 求平均值

1054 求平均值 (20 分)

本题的基本要求非常简单:给定 N 个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是 [−1000,1000] 区间内的实数,并且最多精确到小数点后 2 位。当你计算平均值的时候,不能把那些非法的数据算在内。

输入格式:

输入第一行给出正整数 N(≤100)。随后一行给出 N 个实数,数字间以一个空格分隔。

输出格式:

对每个非法输入,在一行中输出 ERROR: X is not a legal number,其中 X 是输入。最后在一行中输出结果:The average of K numbers is Y,其中 K 是合法输入的个数,Y 是它们的平均值,精确到小数点后 2 位。如果平均值无法计算,则用 Undefined 替换 Y。如果 K 为 1,则输出 The average of 1 number is Y。

输入样例 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

输出样例 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

输入样例 2:

2
aaa -9999

输出样例 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

参考代码

(一)这是只对了三个测试点的代码,估计卡在了“000xxx”这个例子上,虽然只对了三个测试点,但是经过这个代码还是学到了很多。如:

  1. stringstream的使用很简便,头文件为#include 但是在字符串转换成double型时还是有问题,如:
    • 2.3.4可以转换成2.3,而不是0
    • 0033可以转换成33,而不是0
  2. stringstream在循环中使用要注意清空状态和内容!!!

要注意的粗心大坑有:

  • 坑1:不要以为0,就用number
if(num==0) cout<<"The average of 0 number is Undefined";
//这里的输出number是错的,应为:numbers
  • 坑2:大于1的number要用numbers
else printf("The average of %d number is %.2f", num, sum/num);
这里的输出number是错的,应为:numbers
#include <iostream>
#include <sstream>
#include <string>
#include <cmath>
#include <algorithm>
using namespace std;
string s;
bool istrue(string s){
	int cnt1=0, cnt2=0, cnt3=0, cnt4=0, k=0;
	cnt1=count(s.begin(),s.end(),'.');
	cnt2=count(s.begin(),s.end(),'-');
	cnt3=count(s.begin(),s.end(),'+');
	if(cnt1>1 || cnt2>1 || cnt3>1) return false;
	for(int i=0;i<s.length();i++){
		if((s[i]<'0' || s[i]>'9') && s[i]!='.' && s[i]!='-' && s[i]!='+') return false;
	}
	return true;
}
int main(){
    int n, num=0, cnt=0, flag=0;
    double a, sum=0;
    stringstream ss;    //神奇的类型转换魔术通道!!!
    cin>>n;
    for(int i=0;i<n;i++){
		cin>>s;
		if(istrue(s)){
            ss.clear();		//重复利用要清空,清空状态 
            ss.str("");		//清空内容 
        	ss<<s;
        	ss>>a;
            if(a>=-1000 && a<=1000){
                if(fmod(a*1000,10)==0){
                   	num++; 
                   	sum+=a;
                } 
                else cout<<"ERROR: "<<s<<" is not a legal number"<<endl;
            }
            else cout<<"ERROR: "<<s<<" is not a legal number"<<endl;
		} 
        else cout<<"ERROR: "<<s<<" is not a legal number"<<endl;
    }
    if(num==0) cout<<"The average of 0 numbers is Undefined";
    else if(num==1) printf("The average of 1 number is %.2f", sum);
    else printf("The average of %d numbers is %.2f", num, sum/num);
    return 0;
}

(二)这是https://blog.csdn.net/liuchuo/article/details/51994267的AC代码,核心之处在于:

  1. 利用了sscanf和sprintf
sscanf(a, "%lf", &temp);	//将字符串转换成double类型
sprintf(b, "%.2f",temp);	//再将double转换成字符串,利用sprintf的好处是可以控制精度,为下面的							 精彩之处做好铺垫!!!
  1. 精彩之处
for(int j = 0; j < strlen(a); j++)
    if(a[j] != b[j]) flag = 1;	//这样比较是最高效的而且简练

代码部分

#include <iostream>
#include <cstdio>
#include <string.h>
using namespace std;
int main() {
    int n, cnt = 0;
    char a[50], b[50];
    double temp, sum = 0.0;
    cin >> n;
    for(int i = 0; i < n; i++) {
        scanf("%s", a);
        sscanf(a, "%lf", &temp);
        sprintf(b, "%.2f",temp);
        int flag = 0;
        for(int j = 0; j < strlen(a); j++)
            if(a[j] != b[j]) flag = 1;
        if(flag || temp < -1000 || temp > 1000) {
            printf("ERROR: %s is not a legal number\n", a);
            continue;
        } else {
            sum += temp;
            cnt++;
        }
    }
    if(cnt == 1)
        printf("The average of 1 number is %.2f", sum);
    else if(cnt > 1)
        printf("The average of %d numbers is %.2f", cnt, sum / cnt);
    else
        printf("The average of 0 numbers is Undefined");
    return 0;
}

(三)参考上面的代码+stringstream的AC版本

#include <iostream>
#include <cstdio>
#include <sstream>
#include <string>
#include <cmath>
using namespace std;
int main(){
    int n, num=0, flag=0;
    double a, sum=0;
    char st[50];
    string s;
    stringstream ss;    //神奇的类型转换魔术通道!!!
    cin>>n;
    for(int i=0;i<n;i++){
        flag=0;
		cin>>s;
		ss.clear();		//重复利用要清空,清空状态 
		ss.str("");		//清空内容 
        ss<<s;
        ss>>a;
        sprintf(st, "%.2f", a);
        for(int j=0;j<s.length();j++){
            if(s[j] != st[j]) flag = 1;
        }
        if(flag || a < -1000 || a > 1000) {
            cout<<"ERROR: "<<s<<" is not a legal number"<<endl;
            continue;
        } else {
            sum+=a;
            num++;
        }
    }
    if(num==0) cout<<"The average of 0 numbers is Undefined";
    else if(num==1) printf("The average of 1 number is %.2f", sum);
    else printf("The average of %d numbers is %.2f", num, sum/num);
    return 0;
}

这题困扰了我多时,算是告一段落了~~~

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值