1.6 [hduoj] 2056 Rectangles

Problem Description

Given two rectangles and the coordinates of two points on the diagonals of each rectangle,you have to calculate the area of the intersected part of two rectangles. its sides are parallel to OX and OY .

Input

Input The first line of input is 8 positive numbers which indicate the coordinates of four points that must be on each diagonal.The 8 numbers are x1,y1,x2,y2,x3,y3,x4,y4.That means the two points on the first rectangle are(x1,y1),(x2,y2);the other two points on the second rectangle are (x3,y3),(x4,y4).

Output

Output For each case output the area of their intersected part in a single line.accurate up to 2 decimal places.

Sample Input

1.00 1.00 3.00 3.00 2.00 2.00 4.00 4.00

5.00 5.00 13.00 13.00 4.00 4.00 12.50 12.50

Sample Output

1.00

56.25

#include<stdio.h>
#include<math.h>
double a[4];
double max(double a,double b)
{
    if(a>b)
        return a;
    else
        return b;
}
double min(double a,double b)
{
    if(a>b)
        return b;
    else
        return a;
}
void bubblesort(double a[4])
{
    double temp;
    for(int i=0;i<4;i++)
    {
        for(int j=0;j<3-i;j++)
        {
            if(a[j]>a[j+1])
            {
                temp=a[j];
                a[j]=a[j+1];
                a[j+1]=temp;
            }
        }
    }
}
void main()
{
    double x[4],y[4];
    while(scanf("%lf%lf%lf%lf%lf%lf%lf%lf",&x[0],&y[0],&x[1],&y[1],&x[2],&y[2],&x[3],&y[3])!=EOF)
    {
        double maxx1=max(x[0],x[1]);
        double minx1=min(x[0],x[1]);
        double maxy1=max(y[0],y[1]);
        double miny1=min(y[0],y[1]);
        double maxx2=max(x[2],x[3]);
        double minx2=min(x[2],x[3]);
        double maxy2=max(y[2],y[3]);
        double miny2=min(y[2],y[3]);
        if(maxx1<=minx2||maxx2<=minx1||maxy1<=miny2||maxy2<=miny1)
            printf("%.2lf\n",0);
        else
        {
            bubblesort(x);
            bubblesort(y);
            double area=(x[2]-x[1])*(y[2]-y[1]);
 //           printf("%lf %lf %lf %lf\n",x[0],x[1],x[2],x[3]);
            printf("%.2lf\n",area);
        }
    }
}

嗨。这题好麻烦啊。要多画图。然后有两种情况,一种相交,一种不相交。

判断不相交就是,先分别求出两个矩形的最大坐标(包括x轴坐标和y轴坐标),如果其中有最大坐标比另一个最小坐标还小的话(x轴y轴都要判断),就说明不相交。

判断完以后,就可以放心的排序了,对x轴坐标和y轴坐标分别排序,排在中间两个的差的积相乘就是面积(这个表达不清楚,但是多画画图就可以get了)

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值