Combinatorics——HDUOJ 1510 - White Rectangles

原题

  • Problem Description

    You are given a chessboard made up of N squares by N squares with equal size. Some of the squares are colored black, and the others are colored white. Please write a program to calculate the number of rectangles which are completely made up of white squares.

  • Input

    There are multiple test cases. Each test case begins with an integer N (1 <= N <= 100), the board size. The following N lines, each with N characters, have only two valid character values:
    # - (sharp) representing a black square;
    . - (point) representing a white square.
    Process to the end of file.

  • Output

    For each test case in the input, your program must output the number of white rectangles, as shown in the sample output.

  • Sample Input

    2
    1 2
    112233445566778899 998877665544332211

  • Sample Output

    2
    .#
    ..
    4
    ..#.
    ##. #
    .#..
    .#.#

解题思路:

  • 循环遍历延伸,直接暴力检测(HOJ在这道题上的测试数据有点水)

代码:

#include<stdio.h>
#include <iostream>
using namespace std;
char W[101][101];
int SUM;
void Calculate(short N){
    short i, j, k, l, temp;
    for(i = 1; i <= N; i++)
        for (j = 1; j <= N; j++){
            temp = N;
            if(W[i][j] == '#')continue;
            SUM++;//此块为白块
            for (k = j; k <= N; k++){
                if(k != j){
                    if (W[i][k] == '#')break;       
                    SUM++;
                }
                for (l = i + 1; l <= temp; l++){
                    if (W[l][k] == '#') {
                        temp = l - 1;
                        break;
                    }
                    SUM++;
                }
            }
        }
}
int main(){
    short N, i, j;
    while (scanf("%d",&N)!=EOF)
    {
        memset(W, '0', sizeof(W));
        SUM = 0;
        for (i = 1; i <= N; i++)//行
            for (j = 1; j <= N; j++)//列
                cin >> W[i][j];//无需考虑清空缓存
        Calculate(N);
        printf("%d\n", SUM);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值