4.19 PAT 甲级 1004 Counting Leaves

3 篇文章 0 订阅
2 篇文章 0 订阅

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf node

s. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1
#include<iostream>
#include<algorithm>
#include<string.h>

using namespace std;

const int M = 110;
int n,m;                            //n表示树的结点的数量,m表示非叶子结点的数量
int h[M],e[M],ne[M],idx;            //表示邻接表
int depth_num[M],max_depth;         //数组表示每层叶子结点的数量,max_depth表示最大层数

void add(int a,int b)               //这个函数是添加a到b的边,即表明b是a的孩子
{
    e[idx] = b;
    ne[idx] = h[a];
    h[a] = idx ++;
}
void dfs(int depth,int x)
{
    if(h[x] == -1)                 //表明x是叶子结点
    {
        depth_num[depth] ++;
        max_depth = max(depth, max_depth);
        return;
    }
    for(int i = h[x]; ~i; i = ne[i])
    {
        depth ++;
        dfs(depth,e[i]);
    }
}

int main()
{
    cin >> n >> m;

    memset(h,-1,sizeof(h));                //初始化每个头结点
    while(m --)
    {
        int a,t;
        cin >> a >> t;
        while(t --)
        {
            int b;
            cin >> b;
            add(a,b);
        }
    }
    dfs(0,1);

    cout << depth_num[0];
    for(int i = 1; i <= max_depth; i ++ )
        cout << ' ' << depth_num[i];
    cout << endl;

    return 0;
}

输入n和m,n表示这棵树的总结点数,m表示非叶子结点数。接下来m行每行都有几个数字,第一个数字表示一个非叶子结点,然后是k,表示这个非叶子结点有k个孩子结点。然后再输入k个孩子结点。为了方便,01表示根结点。

这题用邻接表来存储整个树的关系。(用数组表示邻接表可参考https://www.acwing.com/activity/content/problem/content/2092/1/

然后再用深度优先遍历,记录好每一层数和最大层数。当搜索到的结点是叶子结点的时候,就在记录每一层有多少叶子结点的数组里。最后根据记录的最大层数,分别输出每一层的叶子结点。

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值