1055 The World‘s Richest (25 分) (排序)

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world's wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤10​5​​) - the total number of people, and K (≤10​3​​) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [−10​6​​,10​6​​]) of a person. Finally there are K lines of queries, each contains three positive integers: M (≤100) - the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:

For each query, first print in a line Case #X: where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person's information occupies a line, in the format

Name Age Net_Worth

The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output None.

Sample Input:

12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

Sample Output:

Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

题意:给出n个人的姓名、年龄和拥有的钱,然后进行k次查询,每次查询输出在年龄区间内的财富值的从大到小的前m个人的信息。如果财富值相同就就先输出年龄小的,如果年龄相同就把名字按照字典序排序输出。
思路:(n和m的悬殊很大,n有10的5次方,m却只有100个)先把所有的人按照财富值排序,再建立一个数组mp标记每个年龄段拥有的人的数量,遍历数组并统计相应年龄的人数,当 当前年龄的人的数量不超过100的时候压入新的数组,多出来的不要压入新数组中(也就是说只取每个年龄的前100名,因为一个年龄段最小的就是一个年龄,即使这样也不会超过100个需要输出),再从这个新的数组里面取符合相应年龄的人的信息。

#include<bits/stdc++.h>
using namespace std;
struct node {
	char name[10];
	int age;
	int money;
} p[100005];
bool cmp(node a,node b) {
	if(a.money!=b.money) return a.money>b.money;
	else if(a.age!=b.age) return a.age<b.age;
	return (strcmp(a.name,b.name)<0);
}
vector<node> v;
map<int,int> mp;
int main() {
	int n,k,m,a,b;
	cin>>n>>k;
	for(int i=0; i<n; i++)
		scanf("%s %d %d",p[i].name,&p[i].age,&p[i].money);
	sort(p,p+n,cmp);
	for(int i=0; i<n; i++) {
		if(mp[p[i].age]<100) {
			mp[p[i].age]++;
			v.push_back(p[i]);
		}
	}
	for(int i=0; i<k; i++) {
		scanf("%d %d %d",&m,&a,&b);
		vector<node> t;
		for(int j=0; j<v.size(); j++)
			if(v[j].age>=a&&v[j].age<=b)
				t.push_back(v[j]);
		printf("Case #%d:\n",i+1);
		int flag=0;
		for(int j=0; j<m&&j<t.size(); j++) {
			printf("%s %d %d\n",t[j].name,t[j].age,t[j].money);
			flag=1;
		}
		if(flag==0) cout<<"None\n";
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值