PAT 1033 To Fill or Not to Fill (25分)

14 篇文章 0 订阅

1033 To Fill or Not to Fill (25分)

With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive numbers: C​max​​ (≤ 100), the maximum capacity of the tank; D (≤30000), the distance between Hangzhou and the destination city; D​avg​​ (≤20), the average distance per unit gas that the car can run; and N (≤ 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: P​i​​, the unit gas price, and D​i​​ (≤D), the distance between this station and Hangzhou, for i=1,⋯,N. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print The maximum travel distance = X where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

Sample Input 1:

50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300

Sample Output 1:

749.17

Sample Input 2:

50 1300 12 2
7.10 0
7.00 600

Sample Output 2:

The maximum travel distance = 1200.00

 

/*
贪心策略:假设现在自己处于A站,要考虑的是A站要不要加油,加多少油的问题。找到当前可达范围内(距离A站cmax*davg)下一个要加油的站B。
A站可达范围内,分三种情况:

①没有加油站,------- 快到终点了,则加适量油到终点;或者 Impossible,则A站加满油到哪算哪;

②有更便宜的加油站 ------- 则找到第一家比A便宜的加油站B,加尽可能少的油(也可能油够直接开过去)到B站;

③只有价格更高的加油站,------则当下A站加满油,寻找相对最便宜的加油站B 开过去。
https://blog.csdn.net/tiantangrenjian/article/details/19175831?utm_medium=distribute.pc_relevant.none-task-blog-BlogCommendFromMachineLearnPai2-1.nonecase&depth_1-utm_source=distribute.pc_relevant.none-task-blog-BlogCommendFromMachineLearnPai2-1.nonecase

*/ 
#include <bits/stdc++.h>
#define inf 0x3f3f3f3f
using namespace std;
struct station {
	double price, dis;
};
bool cmp(station a, station b) {
	return a.dis < b.dis;
}
double cmax, d, davg;
int n;
int main() {

	scanf("%lf%lf%lf%d", &cmax, &d, &davg, &n);
	vector<station> sta(n + 1);
	sta[0] = {0.0, d};
	for(int i = 1; i <= n; i++)
		scanf("%lf%lf", &sta[i].price, &sta[i].dis);
	sort(sta.begin(), sta.end(), cmp);
	double nowdis = 0.0, maxdis = 0.0, nowprice = 0.0, totalPrice = 0.0, leftdis = 0.0;
	if(sta[0].dis != 0) {
		printf("The maximum travel distance = 0.00");
		return 0;
	} else {
		nowprice = sta[0].price;
	}
	while(nowdis < d) {
		maxdis = nowdis + cmax * davg;
		double minPriceDis = 0, minPrice = inf;
		int flag = 0;
		for(int i = 1; i <= n && sta[i].dis <= maxdis; i++) {
			if(sta[i].dis <= nowdis) continue;
			if(sta[i].price < nowprice) {  //寻找里程里油价最低的加油站  里程范围里有比现在加油站便宜的油,直接进到目的地
				totalPrice += (sta[i].dis - nowdis - leftdis) * nowprice / davg;
				leftdis = 0.0;
				nowprice = sta[i].price;
				nowdis = sta[i].dis;
				flag = 1;
				break;
			}
			if(sta[i].price < minPrice) {
				minPrice = sta[i].price;
				minPriceDis = sta[i].dis;
			}
		}
		//接下来里程内没有比现在便宜的加油站,在当前的加油站把油箱加满(先加满最便宜的油) 
		if(flag == 0 && minPrice != inf) {
			totalPrice += (nowprice * (cmax - leftdis / davg));
			leftdis = cmax * davg - (minPriceDis - nowdis);
			nowprice = minPrice;
			nowdis = minPriceDis;
		}
		if(flag == 0 && minPrice == inf) {
			nowdis += cmax * davg;
			printf("The maximum travel distance = %.2f", nowdis);
			return 0;
		}
	}
	printf("%.2f", totalPrice);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值