PAT 1135 Is It A Red-Black Tree (30分) (红黑树)

1135 Is It A Red-Black Tree (30分)

There is a kind of balanced binary search tree named red-black tree in the data structure. It has the following 5 properties:

  • (1) Every node is either red or black.
  • (2) The root is black.
  • (3) Every leaf (NULL) is black.
  • (4) If a node is red, then both its children are black.
  • (5) For each node, all simple paths from the node to descendant leaves contain the same number of black nodes.

For example, the tree in Figure 1 is a red-black tree, while the ones in Figure 2 and 3 are not.

rbf1.jpgrbf2.jpgrbf3.jpg
Figure 1Figure 2Figure 3

For each given binary search tree, you are supposed to tell if it is a legal red-black tree.

Input Specification:

Each input file contains several test cases. The first line gives a positive integer K (≤30) which is the total number of cases. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the preorder traversal sequence of the tree. While all the keys in a tree are positive integers, we use negative signs to represent red nodes. All the numbers in a line are separated by a space. The sample input cases correspond to the trees shown in Figure 1, 2 and 3.

Output Specification:

For each test case, print in a line "Yes" if the given tree is a red-black tree, or "No" if not.

Sample Input:

3
9
7 -2 1 5 -4 -11 8 14 -15
9
11 -2 1 -7 5 -4 8 14 -15
8
10 -7 5 -6 8 15 -11 17

Sample Output:

Yes
No
No

红黑树 

  • (1) Every node is either red or black.(每个结点不是黑的就是红的)【负数是红的,正数是黑的】
  • (2) The root is black.(根结点是黑的)【a[0]>0】
  • (3) Every leaf (NULL) is black.(每个NULL叶子结点都是黑的)
  • (4) If a node is red, then both its children are black.(如果一个结点是红的,那么他的孩子都是黑的)【judge1】
  • (5) For each node, all simple paths from the node to descendant leaves contain the same number of black nodes.(从任意结点到叶子结点的路径中,黑色结点的个数是否相同)【judge2】
//给你一个二叉搜索树,让你判断是不是红黑树
//先序序列 + bst 左小右大
#include <bits/stdc++.h>
using namespace std;
struct node{
	int val;
	node *left, *right;
	node(int v): val(v), left(NULL), right(NULL){} 
};
int k, n, a[33];
void insert(node* &root, int val) {
	if(root == NULL) {
		root = new node(val);
		return;
	}
	if(abs(val) <= abs(root->val)) insert(root->left, val); //根据bst的性质 
	else insert(root->right, val);
}
//判断红色孩子结点是否为黑色 
bool judge1(node *root){
	if(root == NULL) return true;
	//root为红色 
	if(root->val < 0){ 
		if(root->left != NULL && root->left->val < 0) return false;
		if(root->right != NULL && root->right->val < 0) return false;
	}
	//递归判断左右子树
	return judge1(root->left) && judge1(root->right); 
} 
//返回从根节点到NIL之间黑节点的个数 
int getNum(node *root){
	if(root == NULL) return 0;
	int l = getNum(root->left);
	int r = getNum(root->right);
	return root->val > 0 ? max(l, r) + 1 : max(l, r);
}

//检查左右孩子到NIL 黑结点个数是否相同
bool judge2(node *root){
	if(root == NULL) return true;
	int l = getNum(root->left);
	int r = getNum(root->right);
	if(l != r) return false;
	return judge2(root->left) && judge2(root->right);
} 
int main(){
	cin >> k;
	for(int i = 0; i < k; i++) {
		cin >> n;
		memset(a, 0, sizeof(a));
		node *rt = NULL;
		for(int j = 0; j < n; j++) {
			cin >> a[j];
			insert(rt, a[j]);
		} 
		if(a[0] < 0 || judge1(rt) == false || judge2(rt) == false)
			cout << "No" << endl;
		else cout << "Yes" << endl; 
	}
	return 0;
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值