POJ 1087 A Plug for UNIX(网络流)

A Plug for UNIX

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13809 Accepted: 4623

Description

You are in charge of setting up the press room for the inaugural meeting of the United Nations Internet eXecutive (UNIX), which has an international mandate to make the free flow of information and ideas on the Internet as cumbersome and bureaucratic as possible. 
Since the room was designed to accommodate reporters and journalists from around the world, it is equipped with electrical receptacles to suit the different shapes of plugs and voltages used by appliances in all of the countries that existed when the room was built. Unfortunately, the room was built many years ago when reporters used very few electric and electronic devices and is equipped with only one receptacle of each type. These days, like everyone else, reporters require many such devices to do their jobs: laptops, cell phones, tape recorders, pagers, coffee pots, microwave ovens, blow dryers, curling 
irons, tooth brushes, etc. Naturally, many of these devices can operate on batteries, but since the meeting is likely to be long and tedious, you want to be able to plug in as many as you can. 
Before the meeting begins, you gather up all the devices that the reporters would like to use, and attempt to set them up. You notice that some of the devices use plugs for which there is no receptacle. You wonder if these devices are from countries that didn‘t exist when the room was built. For some receptacles, there are several devices that use the corresponding plug. For other receptacles, there are no devices that use the corresponding plug. 
In order to try to solve the problem you visit a nearby parts supply store. The store sells adapters that allow one type of plug to be used in a different type of outlet. Moreover, adapters are allowed to be plugged into other adapters. The store does not have adapters for all possible combinations of plugs and receptacles, but there is essentially an unlimited supply of the ones they do have.

Input

The input will consist of one case. The first line contains a single positive integer n (1 <= n <= 100) indicating the number of receptacles in the room. The next n lines list the receptacle types found in the room. Each receptacle type consists of a string of at most 24 alphanumeric characters. The next line contains a single positive integer m (1 <= m <= 100) indicating the number of devices you would like to plug in. Each of the next m lines lists the name of a device followed by the type of plug it uses (which is identical to the type of receptacle it requires). A device name is a string of at most 24 alphanumeric 
characters. No two devices will have exactly the same name. The plug type is separated from the device name by a space. The next line contains a single positive integer k (1 <= k <= 100) indicating the number of different varieties of adapters that are available. Each of the next k lines describes a variety of adapter, giving the type of receptacle provided by the adapter, followed by a space, followed by the type of plug.

Output

A line containing a single non-negative integer indicating the smallest number of devices that cannot be plugged in.

Sample Input

4 
A 
B 
C 
D 
5 
laptop B 
phone C 
pager B 
clock B 
comb X 
3 
B X 
X A 
X D 

Sample Output

1

Source

East Central North America 1999

给出n,有n个插座(可能相同);给出m,表示有m个电器(电器都不相同,但插头会相同),给出电器名以及插头的类型;给出k,表示有k种转接器(转换器每种都有无限个),给出可以桥接的插头和插座。 问说最少有多少个电器没有插座用

  1. 建一个源点,指向所有电器,容量为1

  2. 所有电器指向他们可以插的那个插头上,容量为1

  3. 如果一个插头可以插到另一个插头,那么将s1指向s2,容量为无限大

  4. 将所有插在电源上的插头指向汇点,容量为1

  5. 然后从源点到汇点求最大流即可

/*
4(四个插座,型号分别为A,B,C,D)
A
B
C
D
5 (五个用电器)
laptop B (laptop所需要的插座是B)
phone C (phone所需要的插座是C)
pager B (同上)
clock B (同上)
comb X (同上)
3 (三个转换器)
B X (可以将B插头转换为X插头)
X A (可以将X插头转换为A插头)
X D (可以将X插头转换为D插头)
*/
#include <iostream>
#include <cstring>
#include <algorithm>
#include <string>
#include <cstdio>
#include <queue>
#include <map>
#include <stack>
using namespace std;
const int inf=0x3f3f3f3f;
const int maxn=110000;
int head[maxn],level[maxn],k;
struct Edge
{
    int v,f;
    int next;
}edge[maxn];
void add_edge(int u,int v,int f)
{
    edge[k].v=v;
    edge[k].f=f;
    edge[k].next=head[u];
    head[u]=k++;

    edge[k].v=u;
    edge[k].f=0;
    edge[k].next=head[v];
    head[v]=k++;
}
int BFS(int s,int t)
{
    memset(level,0,sizeof(level));
    queue<int >que;
    que.push(s);
    level[s]=1;
    while(!que.empty())
    {
        int u=que.front();
        que.pop();
        for(int i=head[u];i!=-1;i=edge[i].next)
        {
            int v=edge[i].v;
            if(level[v]==0&&edge[i].f>0)
            {
                level[v]=level[u]+1;
                if(v==t) return 1;
                que.push(v);
            }
        }
    }return 0;
}
int DFS(int u,int maxf,int t)
{
    if(u==t) return maxf;
    int ans=0;
    for(int i=head[u];i!=-1;i=edge[i].next)
    {
        int v=edge[i].v;
        if(level[v]==level[u]+1&&edge[i].f>0)
        {
            int f=DFS(v,min(maxf-ans,edge[i].f),t);
            edge[i].f-=f;
            edge[i^1].f+=f;
            ans+=f;
            if(ans==maxf)
                return ans;
        }
    }if(ans==0) level[u]=-1;
    return ans;
}
int Dinic(int s,int t)
{
    int ans=0;
    while(BFS(s,t))
    {
        ans+=DFS(s,inf,t);
    }
    return ans;
}
map<string, int > mp;
int main()
{
    int n,m,l;
    string str,ss;
    int index;
    while(scanf("%d",&n)!=EOF)
    {
        int s=0,t=maxn-2;
        index=1;
        mp.clear();
        memset(head,-1,sizeof(head));
        k=0;
        for(int i=1;i<=n;i++)
        {
            cin>>str;
            mp[str]=index++;
            add_edge(mp[str],t,1);//插头到汇点连
        }
        cin>>m;
        for(int i=1;i<=m;i++)
        {
            cin>>ss>>str;
            if(!mp[ss])
                mp[ss]=index++;
            if(!mp[str])
                mp[str]=index++;
            add_edge(s,mp[ss],1);//源点到用电器
            add_edge(mp[ss],mp[str],1);//用电器到插头
        }
        cin>>l;
        for(int i=1;i<=l;i++)
        {
            cin>>ss>>str;
            if(!mp[ss])
                mp[ss]=index++;
            if(!mp[str])
                mp[str]=index++;
            add_edge(mp[ss],mp[str],inf);//转换器
        }
        cout<<m-Dinic(s,t)<<endl;
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值